summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2011-08-09 15:52:50 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2011-08-09 15:52:50 -0500
commit9b981cafaac2d0ad265ad6105fd3715bfc041051 (patch)
tree85093639598c52414e855c3c48d6320a60ba6544 /configure.in
parenta81389fb840f21f855d0f7c900821587d33782da (diff)
Adjust the parallelism of tail_build to be max(max-process, num-cpus)
tail_build run mostly by itself and wrap a dozen of module, using just MAXPROCESS for the parallelism force to limit NB_CPUS in order to avoid a NB_CPUS x MAXPROCESS scenario. This mitigate this problem, until we don;t need MAXPROCESS anymore and NB_CPUS becomes the only driving force.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f9d6d374ea28..f245355bd265 100755
--- a/configure.in
+++ b/configure.in
@@ -9026,6 +9026,18 @@ fi
AC_MSG_RESULT([$BUILD_MAX_JOBS])
AC_SUBST(BUILD_MAX_JOBS)
+# =====================================================================
+# determine the parallelism for tail_build
+# =====================================================================
+AC_MSG_CHECKING([for maximum parallelism for gmake])
+if test $BUILD_MAX_JOBS -gt $BUILD_NCPUS ; then
+ GMAKE_PARALLELISM="$BUILD_MAX_JOBS"
+else
+ GMAKE_PARALLELISM="$BUILD_NCPUS"
+fi
+AC_MSG_RESULT([$GMAKE_PARALLELISM])
+AC_SUBST(GMAKE_PARALLELISM)
+
dnl ===================================================================
dnl Setting up the environment.
dnl ===================================================================