summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@gmail.com>2011-08-24 12:17:31 +0100
committerMichael Meeks <michael.meeks@novell.com>2011-08-24 14:23:43 +0100
commit75fac9839793f73c9833489f1d70bf4136881cbf (patch)
tree30c20c8b5924f84439e1b3b122cde6b8193831e6 /configure.in
parent9ba447cec165946ed8b9e719c4a9ee318f9b051b (diff)
Add support for creating merged library.
This commit allows to set which libraries to merge and creates merged library in tail_build if enabled. This should save time when loading libraries in application and also makes more sense for link-time optimization. Signed-off-by: Michael Meeks <michael.meeks@novell.com>
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 47758331e31b..ad5f63f8101f 100755
--- a/configure.in
+++ b/configure.in
@@ -116,6 +116,11 @@ AC_ARG_ENABLE(ext-wiki-publisher,
dnl ---------- *** ----------
+AC_ARG_ENABLE(mergelibs,
+ AS_HELP_STRING([--enable-mergelibs],
+ [Enables linking of big merged library used for better performance.]),
+,)
+
AC_ARG_ENABLE(graphite,
AS_HELP_STRING([--enable-graphite],
[Enables the compilation of Graphite smart font rendering.]),
@@ -9063,6 +9068,18 @@ fi
AC_MSG_RESULT([$BUILD_NCPUS])
AC_SUBST(BUILD_NCPUS)
+# ===================================================================
+# Creating bigger shared library to link against
+# ===================================================================
+AC_MSG_CHECKING([whether to create a big library for better performance])
+if test "$enable_mergelibs" != "no"; then
+ MERGELIBS="YES"
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(MERGELIBS)
+
dnl ===================================================================
dnl Number of parallel jobs to be executed by dmake
dnl ===================================================================