summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@frugalware.org>2011-08-11 18:36:53 +0200
committerMiklos Vajna <vmiklos@frugalware.org>2011-08-12 00:17:01 +0200
commit44cc719a462ca76a691b64ac286503186f8ec9ed (patch)
tree653f9b48b2c0c19aee2b51a76f885aa6f37b7f11 /configure.in
parent5cbb76d6c4e4d8de7304e75ca922d92320954d5a (diff)
Make the help repo optional
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0b44e8912b76..81cb9a8f2397 100755
--- a/configure.in
+++ b/configure.in
@@ -1019,6 +1019,12 @@ AC_ARG_WITH(gxx_include_path,
],
,)
+AC_ARG_WITH(help,
+ AS_HELP_STRING([--with-help],
+ [Enable the build of help.
+
+ To build without help, use --without-help.]))
+
AC_ARG_WITH(java,
AS_HELP_STRING([--with-java],
[Specify the name of the Java interpreter command. Typically "java"
@@ -1368,7 +1374,7 @@ AC_ARG_WITH(macosx-version-max-allowed,
BUILD_TYPE="LibO"
SCPDEFS=""
-GIT_REPO_NAMES="help"
+GIT_REPO_NAMES=""
echo "********************************************************************"
echo "*"
@@ -2283,6 +2289,16 @@ else
fi
AC_SUBST(WITH_BINFILTER)
+AC_MSG_CHECKING([whether to build help])
+if test "$with_help" != "no" -a $_os != iOS -a $_os != Android; then
+ AC_MSG_RESULT([yes])
+ BUILD_TYPE="$BUILD_TYPE HELP"
+ SCPDEFS="$SCPDEFS -DWITH_HELP"
+ GIT_REPO_NAMES="$GIT_REPO_NAMES help"
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl Enable ugly pieces of code we're better off without
dnl ===================================================================
if test "$enable_ugly" = "yes"; then