summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-02-17 09:51:41 +0100
committerDavid Tardon <dtardon@redhat.com>2012-02-17 15:53:58 +0100
commit1a1c6f8f8e7850741d7d8a31c0f62beae7820a37 (patch)
tree18957ea61a64923cbfea9a57c45ec340531955e2 /configure.in
parentb60aedc17c12db865f5994a579facb10a3e9343e (diff)
allow using system icu in cross-compilation build
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 110c1b2364ba..1b7bce398510 100644
--- a/configure.in
+++ b/configure.in
@@ -1949,6 +1949,10 @@ AC_ARG_WITH(system-expat-for-build,
AS_HELP_STRING([--with-system-expat-for-build],
[Use expat/libxslt already on system for build tools (cross-compilation only).]))
+AC_ARG_WITH(system-icu-for-build,
+ AS_HELP_STRING([--with-system-icu-for-build],
+ [Use icu/libxslt already on system for build tools (cross-compilation only).]))
+
AC_ARG_WITH(system-libxml-for-build,
AS_HELP_STRING([--with-system-libxml-for-build],
[Use libxml/libxslt already on system for build tools (cross-compilation only).]))
@@ -3191,6 +3195,7 @@ if test "$cross_compiling" = "yes"; then
test -n "$with_system_cppunit_for_build" && sub_conf_opts="$sub_conf_opts --with-system-cppunit"
test -n "$with_system_db_for_build" && sub_conf_opts="$sub_conf_opts --with-system-db"
test -n "$with_system_expat_for_build" && sub_conf_opts="$sub_conf_opts --with-system-expat"
+ test -n "$with_system_icu_for_build" && sub_conf_opts="$sub_conf_opts --with-system-icu"
test -n "$with_system_libxml_for_build" && sub_conf_opts="$sub_conf_opts --with-system-libxml"
./configure \
--disable-mozilla \