summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2012-05-07 13:46:09 +0200
committerTomas Chvatal <tchvatal@suse.cz>2012-05-09 17:41:30 +0200
commit27abb730b290f3516582d2d787ef64af76663f97 (patch)
tree5939ae548b224c4c4eaac81ecaba05ab951989f0 /configure.in
parentc7a9318f08e08a35f2784bf8d06f62031649b24e (diff)
Enable configure switch for cups
This allows us not to have cups during the build time of libreoffice. Commit is inspired from patch from Dave Flogeras <dflogeras@gmail.com>. Change-Id: I I32a14eb6e7bdd13de1a737d4798c852a830ae326
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 73f2c48454e6..b09a93588939 100644
--- a/configure.in
+++ b/configure.in
@@ -848,6 +848,11 @@ AC_ARG_ENABLE(nsplugin,
[Do not build nsplugin extension for browser embedding.])
)
+AC_ARG_ENABLE(cups,
+ AS_HELP_STRING([--disable-cups],
+ [Do not build cups support.])
+)
+
AC_ARG_ENABLE(ccache,
AS_HELP_STRING([--disable-ccache],
[Do not try to use ccache automatically.
@@ -3605,6 +3610,13 @@ fi
dnl check for cups support
dnl ===================================================================
+if test "$enable_cups" = "no"; then
+ test_cups=no
+ ENABLE_CUPS="NO"
+else
+ ENABLE_CUPS="YES"
+fi
+AC_SUBST(ENABLE_CUPS)
if test "$test_cups" = "yes"; then
AC_MSG_CHECKING([whether cups support is present])
AC_CHECK_LIB([cups], [cupsPrintFiles], [:])