summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2012-07-26 19:36:35 +0200
committerMichael Stahl <mstahl@redhat.com>2012-07-26 21:02:11 +0200
commite7dec2887e511a18a5f9927884c1a1df45fc35f0 (patch)
tree9e8265d5d2eb1dff8888d04a169cb7bf4f2c8d06 /configure.in
parentb391778d81ea0f67264e09c70c85a0bff9647f99 (diff)
set WINEGCC only when cross compiling
Change-Id: I598490aa71b658844d912008c0cf14e225bda0db
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1a0a72a4073f..5b0aa380c8bf 100644
--- a/configure.in
+++ b/configure.in
@@ -6106,8 +6106,8 @@ AC_SUBST(BUILD_EPM)
dnl ===================================================================
dnl We need winegcc when building MinGW build to be able to cross-build msi tools
dnl ===================================================================
-AC_PATH_PROG(WINEGCC, winegcc)
if test "$WITH_MINGW" = "yes" -a "$PKGFORMAT" = "msi" ; then
+ AC_PATH_PROG(WINEGCC, winegcc)
if test "$WINEGCC" = ""; then
AC_MSG_ERROR([winegcc was not found, please install wine-devel, or wine-devel-32bit])
fi
@@ -6122,6 +6122,7 @@ printf ("hello world\n");
)
CC="$CC_save"
fi
+AC_SUBST(WINEGCC)
dnl ===================================================================
dnl Check for gperf