summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorobo <obo@openoffice.org>2010-06-23 13:38:34 +0200
committerobo <obo@openoffice.org>2010-06-23 13:38:34 +0200
commitdd21c6021cdc4884138dd2effc9d8a6d081c3874 (patch)
tree40c1f4f7bb185e430216b6e77e23b0315b8b1e19 /configure.in
parentabfe0ca9204439f9def2ef9216e3d7c4cd3f1589 (diff)
koheirowlimitperf: #i109369# #i109373# #i109384# #i109385# #i109386# #i109387# #i109388# #i109389# #i109391# #i109934# #i109935# #i110116# #i111531# #i111887# #i112190# #i30215# increased the row limit to 1 million, and integrated lots of speed optimization and bug fixes to ensure Calc remains usable after the row limit increase.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6468f15cebfe..00a5d5dde8b5 100644
--- a/configure.in
+++ b/configure.in
@@ -515,6 +515,9 @@ AC_ARG_WITH(system-curl,
AC_ARG_WITH(system-boost,
[ --with-system-boost Use boost already on system
],,)
+AC_ARG_WITH(system-mdds,
+[ --with-system-mdds Use mdds already on system
+],,)
AC_ARG_WITH(system-vigra,
[ --with-system-vigra Use vigra already on system
],,)
@@ -4178,6 +4181,25 @@ AC_SUBST(CURL_CFLAGS)
AC_SUBST(CURL_LIBS)
dnl ===================================================================
+dnl Check for system mdds
+dnl ===================================================================
+AC_MSG_CHECKING([which mdds to use])
+if test -n "$with_system_mdds" -o -n "$with_system_headers" && \
+ test "$with_system_mdds" != "no"; then
+ AC_MSG_RESULT([external])
+ SYSTEM_MDDS=YES
+ AC_LANG_PUSH([C++])
+ AC_CHECK_HEADER(mdds/flat_segment_tree.hpp, [],
+ [AC_MSG_ERROR(mdds/flat_segment_tree.hpp not found. install mdds)], [])
+ AC_LANG_POP([C++])
+else
+ AC_MSG_RESULT([internal])
+ BUILD_TYPE="$BUILD_TYPE MDDS"
+ SYSTEM_MDDS=NO
+fi
+AC_SUBST(SYSTEM_MDDS)
+
+dnl ===================================================================
dnl Check for system boost
dnl ===================================================================
AC_MSG_CHECKING([which boost to use])