summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorobo <obo@openoffice.org>2010-06-22 15:46:16 +0200
committerobo <obo@openoffice.org>2010-06-22 15:46:16 +0200
commitbc47011daaacc04ce03336412637e15d940db520 (patch)
tree89d2b4184a66d6b02946a568611665ca2e19fb3c /configure.in
parentd3b85f1a0d1d806440301606e06fb45ec3b68d77 (diff)
parentb96df8f62a8f7706bca64c9ab1eb577436a93974 (diff)
CWS-TOOLING: integrate CWS cmcfixes75
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 17 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index 02faf69d6198..6468f15cebfe 100644
--- a/configure.in
+++ b/configure.in
@@ -129,7 +129,7 @@ AC_ARG_ENABLE(evolution2,
],,)
AC_ARG_WITH(system-stdlibs,
[ --with-system-stdlibs use libstdc++/libgcc_s already on system
-],,checkforstdlibproblems=yes)
+],,)
AC_ARG_ENABLE(cups,
[ --disable-cups disable cups support in the psprint project
],,enable_cups=yes)
@@ -813,6 +813,9 @@ AC_ARG_ENABLE(verbose,
[ --enable-verbose Increase build verbosity.
--disable-verbose Decrease build verbosity.
],,)
+AC_ARG_ENABLE(dependency-tracking,
+[ --disable-dependency-tracking Disables generation of dependency information.
+],,)
BUILD_TYPE="OOo"
@@ -3498,23 +3501,6 @@ AC_SUBST(MINGWCXX)
AC_SUBST(MINGWSTRIP)
dnl ===================================================================
-dnl Check for prelinked libgcc_s.so.1
-dnl ===================================================================
-if test "$_os" = "Linux" -a -z "$with_system_stdlibs" -a -z "$with_system_libs"; then
- if test -n "$checkforstdlibproblems"; then
- if test -f /etc/rpm/macros.prelink; then
- with_system_stdlibs=yes
- AC_MSG_WARN([prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override])
- echo "prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override" >> warn
- elif test "$GCC" = "yes" -a ! -e `$CC -print-file-name=libgcc_s.so.1`; then
- with_system_stdlibs=yes
- AC_MSG_WARN([platform doesn't have a libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override])
- echo "platform doesn't have a libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override" >> warn
- fi
- fi
-fi
-
-dnl ===================================================================
dnl Check for system stdlibs
dnl ===================================================================
AC_MSG_CHECKING([whether to provide libstdc++/libgcc_s in the installset])
@@ -6898,6 +6884,19 @@ fi
AC_SUBST(VERBOSE)
dnl ===================================================================
+dnl Hook up OOos nodep environmental variable to automake's equivalent
+dnl --enable-dependency-tracking configure option
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable dependency tracking])
+if test "$enable_dependency_tracking" = "no"; then
+ nodep=TRUE
+ AC_MSG_RESULT([no])
+else
+ AC_MSG_RESULT([yes])
+fi
+AC_SUBST(nodep)
+
+dnl ===================================================================
dnl Setting up the environment.
dnl ===================================================================
echo "********************************************************************"