summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Ostrovsky <David.Ostrovsky@gmx.de>2012-06-07 17:46:31 -0700
committerBjoern Michaelsen <bjoern.michaelsen@canonical.com>2012-06-11 22:03:58 +0200
commitbbdb00c8c57a72f9bc730d3f7aab8a4d4acc6308 (patch)
treeafb06fc3da0900d8b3f26da8ec6dbffc118d6fe4 /configure.in
parent0044bd800b742f28056805bb163ff243cf4095f3 (diff)
disable mozilla per default on all platforms
Change-Id: Ie5e8c7c43d86f060d7733c1787c6382e78c0a463
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 18 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index fb4f3dfd8e4d..48bfd38174d3 100644
--- a/configure.in
+++ b/configure.in
@@ -595,9 +595,9 @@ AC_ARG_ENABLE(pch,
)
AC_ARG_ENABLE(mozilla,
- AS_HELP_STRING([--disable-mozilla],
- [LibreOffice usually includes a strangely hacked up Mozilla binary for your
- platform, to build without this version, use this option.])
+ AS_HELP_STRING([--enable-mozilla],
+ [LibreOffice can include a strangely hacked up Mozilla binary for your
+ platform, to build with this version, use this option.])
)
AC_ARG_ENABLE(epm,
@@ -3611,6 +3611,21 @@ AC_SUBST(UPD)
AC_SUBST(SOURCEVERSION)
dnl ===================================================================
+dnl Set the WITH_MOZILLA variable.
+dnl ===================================================================
+
+AC_MSG_CHECKING([whether to enable build of Mozilla])
+if test "$enable_mozilla" = "yes"; then
+ AC_MSG_RESULT([yes])
+ WITH_MOZILLA=YES
+else
+ AC_MSG_RESULT([no])
+ WITH_MOZILLA=NO
+ enable_mozilla=no
+fi
+AC_SUBST(WITH_MOZILLA)
+
+dnl ===================================================================
dnl Set the ENABLE_CRASHDUMP variable.
dnl ===================================================================
AC_MSG_CHECKING([whether to enable crashdump feature])
@@ -7425,16 +7440,6 @@ else
fi
AC_SUBST(SYSTEM_ODBC_HEADERS)
-AC_MSG_CHECKING([whether to enable build of Mozilla])
-if test "$enable_mozilla" = "no"; then
- AC_MSG_RESULT([no])
- WITH_MOZILLA=NO
-else
- AC_MSG_RESULT([yes])
- WITH_MOZILLA=YES
-fi
-AC_SUBST(WITH_MOZILLA)
-
AC_MSG_CHECKING([whether to build Mozilla addressbook connectivity])
if test "$enable_mozilla" = "no"; then
AC_MSG_RESULT([no])