summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2012-04-02 00:10:17 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2012-06-23 23:23:23 -0500
commita95dbe7ad0bc8cf780bb9142bd9ffca3b0417d18 (patch)
treec5df95ada44e95e356328c993f0114105f1541b6 /configure.in
parent9db88e11882c38cd22564c4a76bb0b878de5fe86 (diff)
Add a configure flag to enable CoreText Support
Change-Id: I0f3865beff53f199fae49e806f308c6dab3e3c11
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d8ab8abd48e2..b1f049d1dc34 100644
--- a/configure.in
+++ b/configure.in
@@ -975,6 +975,11 @@ AC_ARG_ENABLE(postgresql-sdbc,
[Disable the build of the PostgreSQL-SDBC driver.])
)
+AC_ARG_ENABLE(coretext,
+ AS_HELP_STRING([--enable-coretext],
+ [Use CoreText framework on Mac (instead of ATSU).]),
+)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -10093,6 +10098,21 @@ else
fi
AC_SUBST(WITH_HELPPACK_INTEGRATION)
+dnl ===================================================================
+dnl Test whether to use CoreText framework
+dnl ===================================================================
+ENABLE_CORETEXT=NO
+if test "$_os" = "Darwin"; then
+ AC_MSG_CHECKING([whether to use CoreText framework])
+ if test "$enable_coretext" = "yes"; then
+ AC_MSG_RESULT([yes])
+ ENABLE_CORETEXT=YES
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+AC_SUBST(ENABLE_CORETEXT)
+
###############################################################################
# Extensions checking
###############################################################################