summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-07-23 15:21:52 +0300
committerTor Lillqvist <tml@iki.fi>2012-07-23 15:21:52 +0300
commita34126985b7b9fdb86f1bd134332b203b2d1a256 (patch)
tree5b3f9d866dd98fe8bfd2fd170be96c2a50109c04 /configure.in
parent4b5f1d7b2d095e4b41434658b376b6de422bf573 (diff)
Propagate also the OS X SDK version we are building against to the environment
Change-Id: I3c1137bdb1186df773a92c34267b2324ad43ae7e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 783520f09cdc..1006d375ea65 100644
--- a/configure.in
+++ b/configure.in
@@ -2428,7 +2428,7 @@ if test "$_os" = "Darwin"; then
if test ! -d "$MACOSX_SDK_PATH"; then
MACOSX_SDK_PATH="/Xcode3/SDKs/MacOSX10.4u.sdk"
fi
- macosx_sdk_value="1040"
+ MACOSX_SDK_VERSION="1040"
;;
10.5)
MACOSX_SDK_PATH="/Developer/SDKs/MacOSX10.5.sdk"
@@ -2438,19 +2438,19 @@ if test "$_os" = "Darwin"; then
if test ! -d "$MACOSX_SDK_PATH"; then
MACOSX_SDK_PATH="/Xcode3/SDKs/MacOSX10.5.sdk"
fi
- macosx_sdk_value="1050"
+ MACOSX_SDK_VERSION="1050"
AC_MSG_WARN([Building with a SDK > 10.4 is experimental])
echo "Building with a SDK > 10.4 is experimental" >> warn
;;
10.6)
MACOSX_SDK_PATH="`xcode-select -print-path`/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.6.sdk"
- macosx_sdk_value="1060"
+ MACOSX_SDK_VERSION="1060"
AC_MSG_WARN([Building with a SDK > 10.4 is experimental])
echo "Building with a SDK > 10.4 is experimental" >> warn
;;
10.7)
MACOSX_SDK_PATH="`xcode-select -print-path`/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk"
- macosx_sdk_value="1070"
+ MACOSX_SDK_VERSION="1070"
AC_MSG_WARN([Building with SDK 10.7 is known to fail in vcl])
echo "Building with SDK 10.7 is known to fail in vcl" >> warn
;;
@@ -2531,7 +2531,7 @@ if test "$_os" = "Darwin"; then
fi
AC_MSG_CHECKING([that macosx-version-max-allowed is coherent macos-with-sdk])
- if test $MAC_OS_X_VERSION_MAX_ALLOWED -gt $macosx_sdk_value; then
+ if test $MAC_OS_X_VERSION_MAX_ALLOWED -gt $MACOSX_SDK_VERSION; then
AC_MSG_ERROR([the version maximum allowed cannot be greater thatn the sdk level])
else
AC_MSG_RESULT([ok])
@@ -2541,6 +2541,7 @@ if test "$_os" = "Darwin"; then
fi
AC_SUBST(FRAMEWORKSHOME)
AC_SUBST(MACOSX_SDK_PATH)
+AC_SUBST(MACOSX_SDK_VERSION)
AC_SUBST(MACOSX_DEPLOYMENT_TARGET)
AC_SUBST(MAC_OS_X_VERSION_MIN_REQUIRED)
AC_SUBST(MAC_OS_X_VERSION_MAX_ALLOWED)