summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-06-13 18:28:29 +0200
committerDavid Tardon <dtardon@redhat.com>2012-06-13 18:28:29 +0200
commit9ea4189c507455caebaf1c96457b98cac789584a (patch)
tree95f3bea18ae0f0e0d94521b25cec1718a41d0833 /configure.in
parent6e90fdb564c0b2201a6255d5ba1cf1257f2c5f2b (diff)
mingw: fix check for boost date_time dll
Change-Id: I4a31c215d70e6f8f8fc8a768851315b919fba03e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 36f99bd55140..c496eacf4265 100644
--- a/configure.in
+++ b/configure.in
@@ -7335,7 +7335,12 @@ if test "$with_system_boost" = "yes"; then
AX_BOOST_BASE
AX_BOOST_DATE_TIME
mingw_boost_date_time_dll=`echo $BOOST_DATE_TIME_LIB | sed -e 's/^-l//' -e 's/\.dll$//'`
- libo_MINGW_CHECK_DLL([BOOST_DATE_TIME], [$mingw_boost_date_time_dll])
+ libo_MINGW_TRY_DLL([BOOST_DATE_TIME], [$mingw_boost_date_time_dll])
+ if test -z "$MINGW_BOOST_DATE_TIME_DLL"; then
+ # if not found, try again with 'lib' prefix
+ libo_MINGW_CHECK_DLL([BOOST_DATE_TIME],
+ [lib$mingw_boost_date_time_dll])
+ fi
else
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE BOOST"