summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorobo <obo@openoffice.org>2010-06-21 15:14:37 +0200
committerobo <obo@openoffice.org>2010-06-21 15:14:37 +0200
commit86909c184b8ba2cf96e468e1e7f81c8b9ec7d1bc (patch)
tree79e2168a2e1d835ed11bacf15f7a811c2df2b377 /configure.in
parent0d85448c7b1471ca0dd0a0db3fa866a989b5903b (diff)
parente1c983602eb7e448f6154024da6bbd5a3398d319 (diff)
CWS-TOOLING: integrate CWS systemlibc
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0f658c8cbde6..048bdc37d924 100644
--- a/configure.in
+++ b/configure.in
@@ -5134,6 +5134,21 @@ if test "$_os" = "Linux"; then
fi
fi
+if test "$_os" != "WNT"; then
+ AC_CHECK_FUNCS(getopt, HAVE_GETOPT=YES, [HAVE_GETOPT=NO])
+ AC_CHECK_FUNCS(readdir_r, HAVE_READDIR_R=YES, [HAVE_READDIR_R=NO])
+ if test "$HAVE_GETOPT" = "YES" -a "$HAVE_READDIR_R" = "YES"; then
+ SYSTEM_LIBC=YES
+ fi
+else
+ HAVE_GETOPT=NO
+ HAVE_READDIR_R=NO
+ SYSTEM_LIBC=YES
+fi
+AC_SUBST(HAVE_GETOPT)
+AC_SUBST(HAVE_READDIR_R)
+AC_SUBST(SYSTEM_LIBC)
+
dnl =========================================
dnl Check for the Microsoft Platform SDK.
dnl =========================================