summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@suse.cz>2011-08-17 12:15:48 +0200
committerJan Holesovsky <kendy@suse.cz>2011-08-18 09:40:09 +0200
commit65a03924b20852235db5f2ec68cd2d3b1042d8b3 (patch)
treed7066e4ae637218dadc6ac1a715611aec27796e3 /configure.in
parent1641f08f1a09dbdf98d02d5573ea5ac70f508eee (diff)
Check for amd64/atls.lib, and disable ActiveX 64bit component if not present.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in17
1 files changed, 8 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 0b8e3759631f..0fa9fbc7b41a 100755
--- a/configure.in
+++ b/configure.in
@@ -2674,9 +2674,8 @@ if test "$_os" = "WINNT"; then
LINK_X64_BINARY=
LIBMGR_X64_BINARY=
- if test "$CL_X64" = ""; then
- AC_MSG_CHECKING([for a x64 compiler])
-
+ AC_MSG_CHECKING([for a x64 compiler and libraries for 64bit ActiveX component])
+ if test "$CL_X64" = "" -a -f "$with_cl_home/atlmfc/lib/amd64/atls.lib"; then
# Prefer native x64 compiler to cross-compiler, in case we are running
# the build on a 64-bit OS.
if "$with_cl_home/bin/amd64/cl.exe" -? </dev/null >/dev/null 2>&1; then
@@ -2692,12 +2691,12 @@ if test "$_os" = "WINNT"; then
LINK_X64_BINARY="$with_cl_home/bin/x86_amd64/link.exe"
LIBMGR_X64_BINARY="$with_cl_home/bin/x86_amd64/lib.exe"
fi
- if test "$BUILD_X64" = TRUE; then
- AC_MSG_RESULT([found])
- else
- AC_MSG_RESULT([not found])
- AC_MSG_WARN([Installation set will not contain the 64-bit Explorer extension])
- fi
+ fi
+ if test "$BUILD_X64" = TRUE; then
+ AC_MSG_RESULT([found])
+ else
+ AC_MSG_RESULT([not found])
+ AC_MSG_WARN([Installation set will not contain the 64-bit Explorer extension])
fi
AC_SUBST(BUILD_X64)