summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@openoffice.org>2010-06-22 16:25:28 +0200
committerRene Engelhard <rene@openoffice.org>2010-06-22 16:25:28 +0200
commit3567bc82df0b228b5e4ae93e9751b174b33f0440 (patch)
tree7ff08f60a010fb0958307f680d78b3eeecf78847 /configure.in
parente26a6b321661c07fce3df199cb22951d3f2c159d (diff)
configure25: move ant version check behind checking whether ant works
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in43
1 files changed, 22 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index cf65165653fd..54ab2ff18b3e 100644
--- a/configure.in
+++ b/configure.in
@@ -6567,27 +6567,6 @@ else
export ANT_HOME
fi
- ant_minver=1.6.0
- # update for more extensions...
- if test "$ENABLE_MEDIAWIKI" = "YES"; then
- ant_minver=1.7.0
- fi
- ant_minminor1=`echo $ant_minver | cut -d"." -f2`
-
- AC_MSG_CHECKING([whether ant is >= $ant_minver])
- ant_version=`$ANT -version | $AWK '{ print $4; }'`
- ant_version_major=`echo $ant_version | cut -d. -f1`
- ant_version_minor=`echo $ant_version | cut -d. -f2`
-echo "configure: ant_version $ant_version " >&5
-echo "configure: ant_version_major $ant_version_major " >&5
-echo "configure: ant_version_minor $ant_version_minor " >&5
- if test "$ant_version_major" -ge "2"; then
- AC_MSG_RESULT([yes, $ant_version])
- elif test "$ant_version_major" = "1" && test "$ant_version_minor" -ge "$ant_minminor1"; then
- AC_MSG_RESULT([yes, $ant_version])
- else
- AC_MSG_ERROR([no, you need at least ant >= $ant_minver])
- fi
AC_MSG_CHECKING([if $ANT works])
cat > conftest.java << EOF
public class conftest {
@@ -6668,6 +6647,28 @@ fi
AC_SUBST(ANT_LIB)
fi
+ant_minver=1.6.0
+# update for more extensions...
+if test "$ENABLE_MEDIAWIKI" = "YES"; then
+ ant_minver=1.7.0
+fi
+ant_minminor1=`echo $ant_minver | cut -d"." -f2`
+
+AC_MSG_CHECKING([whether ant is >= $ant_minver])
+ant_version=`$ANT -version | $AWK '{ print $4; }'`
+ant_version_major=`echo $ant_version | cut -d. -f1`
+ant_version_minor=`echo $ant_version | cut -d. -f2`
+echo "configure: ant_version $ant_version " >&5
+echo "configure: ant_version_major $ant_version_major " >&5
+echo "configure: ant_version_minor $ant_version_minor " >&5
+if test "$ant_version_major" -ge "2"; then
+ AC_MSG_RESULT([yes, $ant_version])
+elif test "$ant_version_major" = "1" && test "$ant_version_minor" -ge "$ant_minminor1"; then
+ AC_MSG_RESULT([yes, $ant_version])
+else
+ AC_MSG_ERROR([no, you need at least ant >= $ant_minver])
+fi
+
if test "$ENABLE_MEDIAWIKI" = "YES"; then
AC_MSG_CHECKING([whether ant supports mapper type="regexp"])
rm -rf confdir