summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsb <sb@openoffice.org>2010-05-20 15:46:46 +0200
committersb <sb@openoffice.org>2010-05-20 15:46:46 +0200
commit09993c4710798dfb1e9c67b2a02a31ce14adab98 (patch)
tree7dfd861fc95b03d54f15c5daba8cca73a07a81c3 /configure.in
parent4aee4ee739adaa21e46876ec1c4ac941d54ed8d5 (diff)
parentff94b38b00f90b4fbc8f49d132d46f27c537e143 (diff)
sb120: merged in DEV300_m78
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 34e9c206b8c8..c6d124b52bae 100644
--- a/configure.in
+++ b/configure.in
@@ -546,6 +546,9 @@ AC_ARG_WITH(system-lpsolve,
AC_ARG_WITH(system-cppunit,
[ --with-system-cppunit Use cppunit already on system
],,)
+AC_ARG_WITH(system-redland,
+[ --with-system-redland Use redland library already on system
+],,)
AC_ARG_WITH(system-mozilla,
[ --with-system-mozilla Use mozilla already on system. Note that some
components cannot be built against a contemporary
@@ -4999,16 +5002,12 @@ dnl ===================================================================
dnl Check for system redland
dnl ===================================================================
AC_MSG_CHECKING([which redland library to use])
-dnl if test -n "$with_system_redland" -o -n "$with_system_libs" && \
-dnl test "$with_system_redland" != "no"; then
-dnl mst: NOTE: right now we need patches against redland
-dnl so we only enable system redland if explicitly requested
-dnl if next version includes patches, insert version check here
-if test -n "$with_system_redland" && \
+if test -n "$with_system_redland" -o -n "$with_system_libs" && \
test "$with_system_redland" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_REDLAND=YES
- PKG_CHECK_MODULES(REDLAND, redland)
+ dnl versions before 1.0.8 write RDF/XML that is useless for ODF (@xml:base)
+ PKG_CHECK_MODULES(REDLAND, redland >= 1.0.8)
else
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE REDLAND"