summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBjoern Michaelsen <b_michaelsen@openoffice.org>2011-01-16 02:56:23 +0100
committerBjoern Michaelsen <b_michaelsen@openoffice.org>2011-01-16 02:56:23 +0100
commit086db699a56e590cc4809dfaec6bc6bf036c9cfe (patch)
tree8106cb5cf574b5cd9f7b281ca2b40356a88c3c94 /configure.in
parentfc199c7b9499dc622307df934f86cdcb25a69b67 (diff)
gnumake3: #i116440# configure should only use a GNU cp from coreutils with preserve= support and fall back to POSIX cp otherwise
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 57b54a4fa12c..98765e4a9b6d 100644
--- a/configure.in
+++ b/configure.in
@@ -5469,19 +5469,19 @@ else
fi
fi
-AC_MSG_CHECKING([whether $GNUCP is GNU cp])
-if $GNUCP --version 2>/dev/null | grep "Free Software Foundation" >/dev/null 2>/dev/null; then
+AC_MSG_CHECKING([whether $GNUCP is GNU cp from coreutils with preserve= support])
+if $GNUCP --version 2>/dev/null | grep "coreutils" >/dev/null 2>/dev/null; then
AC_MSG_RESULT([yes])
else
- if $GNUCP --version 2>/dev/null | grep "GNU fileutils" >/dev/null 2>/dev/null; then
- AC_MSG_RESULT([yes])
+ AC_MSG_RESULT([no])
+ GNUCP=''
+fi
+
+if test -z "$GNUCP"; then
+ if test "$_os" = "SunOS" -o "$_os" = "FreeBSD"; then
+ AC_MSG_ERROR([no, GNU cp from coreutils is needed. install or specify with --with-gnu-cp=/path/to/it])
else
- if test "$_os" = "SunOS" -o "$_os" = "FreeBSD"; then
- AC_MSG_ERROR([no, GNU cp needed. install or specify with --with-gnu-cp=/path/to/it])
- else
- GNUCP=''
- AC_MSG_RESULT([no gnucp found - using the system's cp command])
- fi
+ AC_MSG_RESULT([no GNU cp from coreutils found - using the system's cp command])
fi
fi