summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-06-05 18:01:43 +0300
committerTor Lillqvist <tlillqvist@suse.com>2012-06-05 18:05:16 +0300
commit05cc8975d17b2f2c00e794252c34dc12394abc62 (patch)
treea10340a833d7099a31f68d40e609d24fb95907f7 /configure.in
parent8783ead70cc2bc2a83bf473b0dfb51f3ee10b6da (diff)
PATH for cross-compilations was broken in some way, this seems to fix it
Change-Id: Ifa82be2dfae383ed8570c1d99584e67d85833612
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index bb3eed0e4fb6..8f74557d51f5 100644
--- a/configure.in
+++ b/configure.in
@@ -3555,7 +3555,7 @@ if test "$cross_compiling" = "yes"; then
fi
done
- for V in OUTDIR LO_PATH SOLARINC SOLARLIB WORKDIR; do
+ for V in OUTDIR SOLARINC SOLARLIB WORKDIR; do
VV='$'$V
VV=`eval "echo $VV"`
VV=`echo $VV | sed -e 's,/CONF-FOR-BUILD,,g'`
@@ -3564,6 +3564,10 @@ if test "$cross_compiling" = "yes"; then
echo "$line" >>build-config
fi
done
+
+ line=`echo "LO_PATH_FOR_BUILD=$PATH" | sed -e 's,/CONF-FOR-BUILD,,g'`
+ echo "$line" >>build-config
+
)
test -f CONF-FOR-BUILD/build-config || AC_MSG_ERROR([Running configure script for BUILD system failed, see CONF-FOR-BUILD/config.log])
test -f config_build.mk || AC_MSG_ERROR([A file called config_build.mk was supposed to have been copied here, but it isn't found])