summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2012-01-02 09:42:44 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2012-01-02 09:43:27 -0600
commit9bbb628e1b1b8b3fa97b37679157ce4267089172 (patch)
treec71c3923ab2c1c2ac4fb9c7b693ac3ac4092ac9e /configure.in
parent4f769af98a340a47a01009465bf8ba8eb93509e0 (diff)
oops use == not = in dmake conditional
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in239
1 files changed, 138 insertions, 101 deletions
diff --git a/configure.in b/configure.in
index efb7ca006275..fab7cfc78444 100644
--- a/configure.in
+++ b/configure.in
@@ -6308,6 +6308,7 @@ AC_SUBST(WITH_OPENLDAP)
dnl ===================================================================
dnl Check for system mozilla
dnl ===================================================================
+
AC_MSG_CHECKING([which Mozilla to use])
if test -n "$with_system_mozilla" && test "$with_system_mozilla" != "no"; then
AC_MSG_RESULT([external])
@@ -6370,138 +6371,174 @@ Please recompile $tmp with --enable-ldap or use --with-openldap.])
elif test "$enable_mozilla" = "no"; then
AC_MSG_RESULT([none])
+ x_MOZ=[\#]
WITH_MOZILLA=NO
else
AC_MSG_RESULT([internal])
SYSTEM_MOZILLA=NO
BUILD_TYPE="$BUILD_TYPE MOZ"
-if test -z "$with_mozilla_version"; then
- MOZILLA_VERSION=
-else
- AC_MSG_CHECKING([which Mozilla version to build])
- MOZILLA_VERSION=$with_mozilla_version
- enable_build_mozilla=1
- AC_MSG_RESULT([$MOZILLA_VERSION])
-fi
+ if test -z "$with_mozilla_version"; then
+ MOZILLA_VERSION=
+ else
+ AC_MSG_CHECKING([which Mozilla version to build])
+ MOZILLA_VERSION=$with_mozilla_version
+ enable_build_mozilla=1
+ AC_MSG_RESULT([$MOZILLA_VERSION])
+ fi
-AC_SUBST(MOZILLA_VERSION)
+ AC_SUBST(MOZILLA_VERSION)
-AC_MSG_CHECKING([for toolkit Mozilla should use])
-if test -z "$with_mozilla_toolkit"; then
- if test "$_os" != "WINNT" ; then
- if test "$_os" = "Darwin" ; then
- MOZILLA_TOOLKIT=mac
- AC_MSG_RESULT([mac])
- else
- MOZILLA_TOOLKIT=gtk2
- AC_MSG_RESULT([gtk2])
+ AC_MSG_CHECKING([for toolkit Mozilla should use])
+ if test -z "$with_mozilla_toolkit"; then
+ if test "$_os" != "WINNT" ; then
+ if test "$_os" = "Darwin" ; then
+ MOZILLA_TOOLKIT=mac
+ AC_MSG_RESULT([mac])
+ else
+ MOZILLA_TOOLKIT=gtk2
+ AC_MSG_RESULT([gtk2])
+ fi
fi
+ else
+ MOZILLA_TOOLKIT=$with_mozilla_toolkit
+ enable_build_mozilla=1
+ AC_MSG_RESULT([$MOZILLA_TOOLKIT])
fi
-else
- MOZILLA_TOOLKIT=$with_mozilla_toolkit
- enable_build_mozilla=1
- AC_MSG_RESULT([$MOZILLA_TOOLKIT])
-fi
-AC_SUBST(MOZILLA_TOOLKIT)
+ AC_SUBST(MOZILLA_TOOLKIT)
-# default to enabling build mozilla
-if test "$enable_build_mozilla" != "no"; then
- enable_build_mozilla=yes
-else
- enable_build_mozilla=
-fi
+ # default to enabling build mozilla
+ if test "$enable_build_mozilla" != "no"; then
+ enable_build_mozilla=yes
+ else
+ enable_build_mozilla=
+ fi
-AC_MSG_CHECKING([whether to build Mozilla/SeaMonkey])
-if test -n "$enable_build_mozilla"; then
- BUILD_MOZAB="TRUE"
- AC_MSG_RESULT([yes])
-else
- BUILD_MOZAB=""
- AC_MSG_RESULT([no])
-fi
+ AC_MSG_CHECKING([whether to build Mozilla/SeaMonkey])
+ if test -n "$enable_build_mozilla"; then
+ BUILD_MOZAB="TRUE"
+ AC_MSG_RESULT([yes])
+ else
+ BUILD_MOZAB=""
+ AC_MSG_RESULT([no])
+ fi
-if test "$BUILD_MOZAB" = "TRUE"; then
- if test "$_os" = "WINNT"; then
- if test "$WITH_MINGW" != "yes"; then
- # compiling with MSVC. Only supported platform here is MSVS2005 at the moment.
- if test "$MSVSVER" != "2005"; then
- AC_MSG_ERROR([Building SeaMonkey is supported with Microsoft Visual Studio 2005 only.])
+ if test "$BUILD_MOZAB" = "TRUE"; then
+ if test "$_os" = "WINNT"; then
+ if test "$WITH_MINGW" != "yes"; then
+ # compiling with MSVC. Only supported platform here is MSVS2005 at the moment.
+ if test "$MSVSVER" != "2005"; then
+ AC_MSG_ERROR([Building SeaMonkey is supported with Microsoft Visual Studio 2005 only.])
+ fi
+ else
+ AC_MSG_WARN([Building SeaMonkey with MinGW is not tested, and likely to break.])
+ echo "Building SeaMonkey with MinGW is not tested, and likely to break." >> warn
fi
- else
- AC_MSG_WARN([Building SeaMonkey with MinGW is not tested, and likely to break.])
- echo "Building SeaMonkey with MinGW is not tested, and likely to break." >> warn
fi
- fi
- if test -z "$MOZILLA_VERSION"; then
- MOZILLA_VERSION=1.1.14
- fi
- MOZILLA_SOURCE_VERSION="seamonkey-${MOZILLA_VERSION}.source"
- MOZILLA_FETCH_FILE=`grep $MOZILLA_SOURCE_VERSION ooo.lst.in`
- AC_MSG_CHECKING([for Mozilla sources])
- if test -z "$MOZILLA_FETCH_FILE"; then
- AC_MSG_RESULT([not found])
- HAVE_MOZILLA_TARBALL=n
- else
- AC_MSG_CHECKING([for $MOZILLA_FETCH_FILE])
- if test ! -e "$TARFILE_LOCATION/$MOZILLA_FETCH_FILE"; then
- if test -z "$DO_FETCH"; then
- AC_MSG_RESULT([will be fetched])
- HAVE_MOZILLA_TARBALL=y
+ if test -z "$MOZILLA_VERSION"; then
+ MOZILLA_VERSION=1.1.14
+ fi
+ MOZILLA_SOURCE_VERSION="seamonkey-${MOZILLA_VERSION}.source"
+ MOZILLA_FETCH_FILE=`grep $MOZILLA_SOURCE_VERSION ooo.lst.in`
+ AC_MSG_CHECKING([for Mozilla sources])
+ if test -z "$MOZILLA_FETCH_FILE"; then
+ AC_MSG_RESULT([not found])
+ HAVE_MOZILLA_TARBALL=n
+ else
+ AC_MSG_CHECKING([for $MOZILLA_FETCH_FILE])
+ if test ! -e "$TARFILE_LOCATION/$MOZILLA_FETCH_FILE"; then
+ if test -z "$DO_FETCH"; then
+ AC_MSG_RESULT([will be fetched])
+ HAVE_MOZILLA_TARBALL=y
+ else
+ AC_MSG_RESULT([not found])
+ HAVE_MOZILLA_TARBALL=n
+ fi
else
- AC_MSG_RESULT([not found])
- HAVE_MOZILLA_TARBALL=n
+ AC_MSG_RESULT([found])
+ HAVE_MOZILLA_TARBALL=y
fi
- else
- AC_MSG_RESULT([found])
- HAVE_MOZILLA_TARBALL=y
fi
- fi
- if test "$HAVE_MOZILLA_TARBALL" != "y"; then
- AC_MSG_ERROR([Mozilla/SeaMonkey source archive not found.
+ if test "$HAVE_MOZILLA_TARBALL" != "y"; then
+ AC_MSG_ERROR([Mozilla/SeaMonkey source archive not found.
Use "./download" to download.])
- fi
- if test "$_os" = "WINNT"; then
- AC_MSG_CHECKING([for moztools binaries])
- if test ! -e "$TARFILE_LOCATION/vc8-moztools.zip" ; then
- AC_MSG_ERROR([The following file is missing in $TARFILE_LOCATION: vc8-moztools.zip
-(from ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/historic/vc8/)])
- else
- AC_MSG_RESULT([ok])
- fi
- elif test "$_os" = "Darwin"; then
- PKG_CHECK_MODULES(MOZLIBREQ, libIDL-2.0 >= 0.6.3, MOZIDL="TRUE", MOZIDL="")
- if test -z "$MOZIDL"; then
- AC_MSG_ERROR([libIDL 0.6.3 or newer is needed to build Mozilla with Mac toolkit.])
fi
- else
- # Generic Unix/Linux section
- if test "$MOZILLA_TOOLKIT" = "gtk2"; then
- PKG_CHECK_MODULES(MOZLIBREQ, gtk+-2.0, MOZGTK="TRUE", MOZGTK="")
- if test -z "$MOZGTK"; then
- AC_MSG_ERROR([GTK2 is needed to build Mozilla.])
+ if test "$_os" = "WINNT"; then
+ AC_MSG_CHECKING([for moztools binaries])
+ if test ! -e "$TARFILE_LOCATION/vc8-moztools.zip" ; then
+ AC_MSG_ERROR([The following file is missing in $TARFILE_LOCATION: vc8-moztools.zip
+(from ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/historic/vc8/)])
+ else
+ AC_MSG_RESULT([ok])
fi
- PKG_CHECK_MODULES(MOZLIBREQ, libIDL-2.0 >= 0.8.0, MOZIDL="TRUE", MOZIDL="")
+ elif test "$_os" = "Darwin"; then
+ PKG_CHECK_MODULES(MOZLIBREQ, libIDL-2.0 >= 0.6.3, MOZIDL="TRUE", MOZIDL="")
if test -z "$MOZIDL"; then
- AC_MSG_ERROR([libIDL >= 0.8.0 is needed when using GTK2 to build Mozilla.])
+ AC_MSG_ERROR([libIDL 0.6.3 or newer is needed to build Mozilla with Mac toolkit.])
fi
else
- PKG_CHECK_MODULES(MOZLIBREQ, gtk+ >= 1.2.3, MOZGTK="TRUE", MOZGTK="")
- if test -z "$MOZGTK"; then
- AC_MSG_ERROR([GTK+ 1.2 is needed when not using GTK2 to build Mozilla.])
+ # Generic Unix/Linux section
+ if test "$MOZILLA_TOOLKIT" = "gtk2"; then
+ PKG_CHECK_MODULES(MOZLIBREQ, gtk+-2.0, MOZGTK="TRUE", MOZGTK="")
+ if test -z "$MOZGTK"; then
+ AC_MSG_ERROR([GTK2 is needed to build Mozilla.])
+ fi
+ PKG_CHECK_MODULES(MOZLIBREQ, libIDL-2.0 >= 0.8.0, MOZIDL="TRUE", MOZIDL="")
+ if test -z "$MOZIDL"; then
+ AC_MSG_ERROR([libIDL >= 0.8.0 is needed when using GTK2 to build Mozilla.])
+ fi
+ else
+ PKG_CHECK_MODULES(MOZLIBREQ, gtk+ >= 1.2.3, MOZGTK="TRUE", MOZGTK="")
+ if test -z "$MOZGTK"; then
+ AC_MSG_ERROR([GTK+ 1.2 is needed when not using GTK2 to build Mozilla.])
+ fi
+ PKG_CHECK_MODULES(MOZLIBREQ, libidl >= 0.6.3 libidl <= 0.6.8, MOZIDL="TRUE", MOZIDL="")
+ if test -z "$MOZIDL"; then
+ AC_MSG_ERROR([libIDL 0.6.3 - 0.6.8 is needed when not using GTK2 to build Mozilla.])
+ fi
fi
- PKG_CHECK_MODULES(MOZLIBREQ, libidl >= 0.6.3 libidl <= 0.6.8, MOZIDL="TRUE", MOZIDL="")
- if test -z "$MOZIDL"; then
- AC_MSG_ERROR([libIDL 0.6.3 - 0.6.8 is needed when not using GTK2 to build Mozilla.])
+ fi
+ else
+ AC_MSG_CHECKING([which pre-built Mozilla module in moz/zipped])
+ if test -e "$SRC_ROOT/moz/zipped/${OS}${COM}${CPU}inc.zip" -a \
+ -e "$SRC_ROOT/moz/zipped/${OS}${COM}${CPU}lib.zip" -a \
+ -e "$SRC_ROOT/moz/zipped/${OS}${COM}${CPU}runtime.zip" ; then
+ AC_MSG_RESULT([Found])
+ PREBUILD_MOZAB="YES"
+ if test "$_os" = "cygwin" ; then
+ AC_MSG_CHECKING([for MSVC 2005 runtime needed for prebuilt Mozilla])
+ if test -e "$SRC_ROOT/external/msvcp80/Microsoft.VC80.CRT.manifest" -a \
+ -e "$SRC_ROOT/external/msvcp80/msvcp80.dll" -a \
+ -e "$SRC_ROOT/external/msvcp80/msvcr80.dll" ; then
+ AC_MSG_RESULT([Found])
+ else
+ AC_MSG_RESULT([Not Found])
+ AC_MSG_ERROR([For the pre-built Mozilla libraries, you need MSVC 2005 runtime files
+Microsoft.VC80.CRT.manifest, msvcp80.dll, and msvcr80.dll
+in external/msvcp80.
+
+You can get them by installing:
+<http://download.microsoft.com/download/8/B/4/8B42259F-5D70-43F4-AC2E-4B208FD8D66A/vcredist_x86.EXE>
+and copying the abovementioned files from:
+c:/windows/winsxs/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.4053_x-ww_e6967989/
+and
+c:/windows/winsxs/manifests/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.4053_x-ww_e6967989.manifest
+])
+ fi
fi
+ else
+ AC_MSG_RESULT([Not Found])
+ AC_MSG_ERROR([If you don't use system mozilla and also disable the build of internal mozilla, you must provided the appropriate libraries yourself.
+You need to copy $OS$COM$CPU{inc,lib,runtime}.zip into moz/zipped.
+These files can be found at <http://dev-www.libreoffice.org/mozilla/>
+])
fi
fi
fi
-
+AC_SUBST(x_MOZ)
AC_SUBST(BUILD_MOZAB)
-
-fi
+AC_SUBST(PREBUILT_MOZAB)
AC_SUBST(MOZILLABUILD)
AC_SUBST(SYSTEM_MOZILLA)
AC_SUBST(MOZ_FLAVOUR)