summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-08-23 12:26:52 +0300
committerTor Lillqvist <tml@iki.fi>2012-08-23 12:28:59 +0300
commitc02e838ec21408cd5ba70e0e7b53309411d49db2 (patch)
tree78b234861752bd7741e77be3e80d7a4ed2833de8 /configure.in
parent6737f12e0a4a10a591dcc780de586f205e094f2f (diff)
Factor out the Android APP_ABI sanely instead of copy-paste galore
Change-Id: I66e97d73c410ac6f2e481ba9b2b22183f57438bd
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 39aaecc1fcd7..94c8243fdc4f 100644
--- a/configure.in
+++ b/configure.in
@@ -178,12 +178,16 @@ if test -n "$with_android_ndk"; then
test -z "$STRIP" && STRIP=$ANDROID_ABI_PREBUILT_BIN/$android_gcc_prefix-strip
if test $host_cpu = arm; then
- ANDROIDCFLAGS="-Wno-psabi -march=armv7-a -mfloat-abi=softfp -mfpu=neon -Wl,--fix-cortex-a8 --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-arm -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR}libs/armeabi-v7a"
+ ANDROID_APP_ABI=armeabi-v7a
+ ANDROIDCFLAGS="-march=armv7-a -mfloat-abi=softfp -mfpu=neon -Wl,--fix-cortex-a8"
elif test $host_cpu = mips; then
- ANDROIDCFLAGS="-Wno-psabi --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-mips -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR}libs/mips"
+ ANDROID_APP_ABI=mips
+ ANDROIDCFLAGS=""
else # x86
- ANDROIDCFLAGS="-Wno-psabi -march=atom --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-x86 -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR}libs/x86"
+ ANDROID_APP_ABI=x86
+ ANDROIDCFLAGS="-march=atom"
fi
+ ANDROIDCFLAGS="$ANDROIDCFLAGS -Wno-psabi --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-$android_cpu -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR}libs/$ANDROID_APP_ABI"
# When using the 4.6 or newer toolchain, use the gold linker
case "$with_android_ndk_toolchain_version" in
@@ -218,6 +222,7 @@ fi
AC_SUBST(ANDROID_NDK_HOME)
AC_SUBST(ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR)
AC_SUBST(ANDROID_NDK_GDBSERVER)
+AC_SUBST(ANDROID_APP_ABI)
dnl ===================================================================
dnl Also --with-android-sdk is mandatory