summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-08-09 23:42:17 +0300
committerTor Lillqvist <tml@iki.fi>2012-08-09 23:42:17 +0300
commit13df2ce5c4ebeb270146678956b97a5a95053a55 (patch)
treed44872d45bc78108f5d73eb4e49965dd51ae37dd /configure.in
parent01346afea4a45a2470716d5a7ba18fcce14c475b (diff)
Don't check $cross_compiling until it has been detected more reliably
Change-Id: I00b2a29d30bee2e71b0a04790b6de48bbbacae8a
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 0f56209e419e..0436625789b2 100644
--- a/configure.in
+++ b/configure.in
@@ -66,14 +66,6 @@ dnl do this before argument processing to allow for platform dependent defaults
dnl ===================================================================
AC_CANONICAL_HOST
-if test "$cross_compiling" = "yes"; then
- CROSS_COMPILING=YES
-else
- CROSS_COMPILING=
- BUILD_TYPE="$BUILD_TYPE NATIVE"
-fi
-AC_SUBST(CROSS_COMPILING)
-
AC_PROG_EGREP
# AC_PROG_EGREP doesn't set GREP on all systems as well
AC_PATH_PROG(GREP, grep)
@@ -2761,6 +2753,14 @@ AC_SUBST(ENABLE_DIRECTX)
AC_SUBST(DISABLE_ACTIVEX)
AC_SUBST(DISABLE_ATL)
+if test "$cross_compiling" = "yes"; then
+ CROSS_COMPILING=YES
+else
+ CROSS_COMPILING=
+ BUILD_TYPE="$BUILD_TYPE NATIVE"
+fi
+AC_SUBST(CROSS_COMPILING)
+
dnl ===================================================================
dnl Test the gcc version
dnl ===================================================================