summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-01-16 16:42:51 +0200
committerTor Lillqvist <tlillqvist@suse.com>2012-01-16 16:53:49 +0200
commit081d76c3faa9f242e70f94a253d334e29b7e6595 (patch)
treea45bb8f581b1efcf187ad2cefd51eebb9fad251e /configure.in
parent6c1852c5526a947f2fb6007dc6a85da588e04b61 (diff)
Attempt to manage without Berkeley DB on iOS and Android
Berkeley DB is used for help index and extension database. (Possibly only for a backward-compatible format of the latter, I am not sure.) Neither use makes much sense on Android and iOS. The existing help is for LO on desktop OSes anyway, help for LO-based apps on iOS and Android will naturally be quite different. On iOS there will definitely be no "extensions", and probably we don't want to bother with such on Android either.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 84c1dcc24531..1fccd1eeacb5 100644
--- a/configure.in
+++ b/configure.in
@@ -5819,10 +5819,12 @@ or install the Berkeley db development package.])
SCPDEFS="$SCPDEFS -DSYSTEM_DB"
MINGW_EXTERNAL_DLLS="$MINGW_EXTERNAL_DLLS libdb-4.8.dll"
-else
+elif test $_os != iOS -a $_os != Android; then
AC_MSG_RESULT([internal])
SYSTEM_DB=NO
BUILD_TYPE="$BUILD_TYPE BERKELEYDB"
+else
+ AC_MSG_RESULT([none])
fi
AC_SUBST(SYSTEM_DB)
AC_SUBST(SYSTEM_DB_CFLAGS)