summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndras Timar <atimar@suse.com>2011-11-18 23:40:08 +0100
committerAndras Timar <atimar@suse.com>2011-11-18 23:47:35 +0100
commit949ee7c30806357a5e7fc678c7bbf53f991c71e8 (patch)
tree855b44ad5b9c51d8f98291dc79f47f87b8915089 /configure.in
parent59a0064c2a195368379c5816640737e787550207 (diff)
add --enable-silent-msi configure switch
On Windows it is now configurable to create an MSI installer which installs LibreOffice without user interaction.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 99566667b837..b50da2e1af86 100644
--- a/configure.in
+++ b/configure.in
@@ -806,6 +806,11 @@ AC_ARG_ENABLE(release-build,
See http://wiki.documentfoundation.org/DevBuild]),
,)
+AC_ARG_ENABLE(silent-msi,
+ AS_HELP_STRING([--enable-silent-msi],
+ [Enable MSI with LIMITUI=1 (silent install).]),
+,)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -8459,6 +8464,19 @@ fi
AC_SUBST(ENABLE_RELEASE_BUILD)
dnl ===================================================================
+dnl Test whether to create MSI with LIMITUI=1 (silent install)
+dnl ===================================================================
+AC_MSG_CHECKING([whether to create MSI with LIMITUI=1 (silent install)])
+if test "z$enable_silent_msi" = "z" -o "z$enable_silent_msi" = "zno" ; then
+ AC_MSG_RESULT([no])
+ ENABLE_SILENT_MSI="FALSE"
+else
+ AC_MSG_RESULT([yes])
+ ENABLE_SILENT_MSI="TRUE"
+fi
+AC_SUBST(ENABLE_SILENT_MSI)
+
+dnl ===================================================================
dnl Test whether to enable ActiveX embedding
dnl ===================================================================
if test "$_os" = "WINNT"; then