summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKalman Szalai - KAMI <kami911@gmail.com>2011-11-29 17:12:02 +0100
committerKalman Szalai - KAMI <kami911@gmail.com>2011-11-29 17:14:44 +0100
commit8aa73a8f74cfcdc2fffdc16c8094bd257c8ade0d (patch)
tree73dbd990733ec30d4877892aa3fde8b736525ef2 /configure.in
parent71e77655660fa719ca0e91c7daa94e045e3006a3 (diff)
Add enable-oxygenoffice configure switch
Now only handling brand downloading
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3e3671fd5fca..005a68e7422f 100644
--- a/configure.in
+++ b/configure.in
@@ -784,6 +784,11 @@ AC_ARG_ENABLE(extra-font,
[Add extra font content.]),
,)
+AC_ARG_ENABLE(oxygenoffice,
+ AS_HELP_STRING([--enable-oxygenoffice],
+ [Download OxygenOffice branding and set custom settings.]),
+,)
+
AC_ARG_ENABLE(lomenubar,
AS_HELP_STRING([--enable-lomenubar],
[Enable global menu support.]),
@@ -8437,6 +8442,22 @@ AC_SUBST(WITH_EXTRA_FONT)
AC_SUBST(OOOP_FONTS_PACK)
dnl ===================================================================
+dnl Test whether to download OxygenOffice branding and set custom settings
+dnl ===================================================================
+AC_MSG_CHECKING([whether to download OxygenOffice branding and set custom settings])
+if test "z$enable_oxygenoffice" = "z" -o "z$enable_oxygenoffice" = "zno" ; then
+ AC_MSG_RESULT([no])
+ ENABLE_OXYGENOFFICE=NO
+else
+ AC_MSG_RESULT([yes])
+ ENABLE_OXYGENOFFICE=YES
+ OXYGENOFFICE_PACK="18bf204479ff641d99a88cd71f6f25f7-oxygenoffice-001.zip"
+ BUILD_TYPE="$BUILD_TYPE OXYGENOFFICE"
+fi
+AC_SUBST(ENABLE_OXYGENOFFICE)
+AC_SUBST(OXYGENOFFICE_PACK)
+
+dnl ===================================================================
dnl Test whether to build global menu support
dnl ===================================================================
AC_MSG_CHECKING([whether to build global menu support])