summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2011-11-25 00:41:00 +0200
committerTor Lillqvist <tlillqvist@suse.com>2011-11-25 00:41:00 +0200
commit82a8643ba66b6ef6fe74a417d7a3d7419691bb56 (patch)
tree65fbd605b3f8adabb5a2cf3839c8dcda7b0c5442 /configure.in
parent53e9130dd25fdb66fb6122553cc587ddefc51047 (diff)
Improve build-time Java checks when cross-compiling from MacOSX
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7cbbc779c6ea..6b2d37adb609 100644
--- a/configure.in
+++ b/configure.in
@@ -4197,7 +4197,7 @@ if test "$SOLAR_JAVA" != ""; then
fi
dnl now that we have the path to the real javac, make a JAVA_HOME out of it..
if test "$JAVA_HOME" != "/usr"; then
- if test "$_os" = "Darwin"; then
+ if test "$_os" = "Darwin" -o "$OS_FOR_BUILD" = MACOSX; then
dnl Leopard returns a non-suitable path with readlink - points to "Current" only
JAVA_HOME=$(echo $JAVA_HOME | $SED -e s,/Current/Commands/javac$,/CurrentJDK/Home,)
dnl Tiger already returns a JDK path..
@@ -4254,7 +4254,7 @@ _ACEOF
dnl second sanity check JAVA_HOME if possible
if test "$JDK" != "gcj" -o "$_gij_longver" -ge "40200"; then
# now check if $JAVA_HOME is really valid
- if test "$_os" = "Darwin"; then
+ if test "$_os" = "Darwin" -o "$OS_FOR_BUILD" = MACOSX; then
if test ! -f "$JAVA_HOME/lib/jvm.cfg" -a "x$with_jdk_home" = "x"; then
JAVA_HOME_OK="NO"
fi