summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-01-23 15:08:36 +0100
committerStephan Bergmann <sbergman@redhat.com>2012-01-23 18:07:52 +0100
commit3a7ae48b6f610899200ae2800706533f7c4c9f80 (patch)
tree6e00a466a3af145e83eb6490b65af1abca7cbc81 /configure.in
parent2ec3bc43e1d00ae1911397883976c3724f0bfe14 (diff)
fdo#45090: Changed postgresql-sdbc from bundled oxt to proper optional part.
Replaced --enable-ext-postgresql-sdbc with --disable-postgresql-sdbc. Renamed postgresql-sdbc.uno{.ini,rc} to consistent postgresql-sdbc.ini (which made the code a little easier). Signed-off-by: Fridrich Štrba <fridrich.strba@bluewin.ch>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 8 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index b15f76c685f8..109bc7d04253 100644
--- a/configure.in
+++ b/configure.in
@@ -355,11 +355,6 @@ AC_ARG_ENABLE(ext-pdfimport,
[Disable the PDF Import extension.])
)
-AC_ARG_ENABLE(ext-postgresql-sdbc,
- AS_HELP_STRING([--enable-ext-postgresql-sdbc],
- [Enable the build of the PostgreSQL-SDBC extension.])
-)
-
AC_ARG_ENABLE(ext-presenter-console,
AS_HELP_STRING([--disable-ext-presenter-console],
[Disable the Presenter Console extension.])
@@ -807,6 +802,11 @@ AC_ARG_ENABLE(silent-msi,
[Enable MSI with LIMITUI=1 (silent install).]),
,)
+AC_ARG_ENABLE(postgresql-sdbc,
+ AS_HELP_STRING([--disable-postgresql-sdbc],
+ [Disable the build of the PostgreSQL-SDBC driver.])
+)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -1118,7 +1118,7 @@ AC_ARG_WITH(system-mysql-cppconn,
AC_ARG_WITH(system-postgresql,
AS_HELP_STRING([--with-system-postgresql],
[Use PostgreSQL libraries already on system, for building the PostgreSQL-SDBC
- extension. If pg_config is not in PATH, use PGCONFIG to point to it.]),,
+ driver. If pg_config is not in PATH, use PGCONFIG to point to it.]),,
[with_system_postgresql="$with_system_libs"])
AC_ARG_WITH(libpq-path,
@@ -5388,11 +5388,8 @@ dnl ===================================================================
dnl Check for PostgreSQL stuff
dnl ===================================================================
-if test "x$enable_ext_postgresql_sdbc" = "xyes"; then
- if test "x$enable_extension_integration" = "xyes"; then
- SCPDEFS="$SCPDEFS -DWITH_EXTENSION_POSTGRESQL"
- fi
-
+if test "x$enable_postgresql_sdbc" != "xno"; then
+ SCPDEFS="$SCPDEFS -DWITH_POSTGRESQL_SDBC"
AC_MSG_CHECKING([PostgreSQL C interface])
if test "$with_system_postgresql" = "yes"; then
AC_MSG_RESULT([external PostgreSQL])