summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2011-12-15 16:59:17 +0100
committerLuboš Luňák <l.lunak@suse.cz>2011-12-15 17:02:36 +0100
commite87fc0bfde8bd48b449e123c1bdd28e1359e8c77 (patch)
tree63947d2f20cd72567fd85646e5fa386ba4e2e7bc /configure.in
parentf269629d1b0182d89b2f5a769fbb0f8dcb815ec3 (diff)
Revert "enable -gdwarf-4 by default if possible"
It turns out even quite recent gdb (7.1) reportedly does not support DWARF4, moreover while the produced binaries are smaller, faster and make gdb initially use less memory, this quickly ceases to the case as soon as one actually does anything in gdb. Presumably the DWARF4 handling in current gdb is very inefficient (http://sourceware.org/bugzilla/show_bug.cgi?id=13498). This reverts commit 5214f7843ca48f2207945fbfe32ba164afe7b3aa. Conflicts: solenv/gbuild/platform/WNT_INTEL_GCC.mk solenv/gbuild/platform/unxgcc.mk
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index 59cb7fb793f3..354fa521a23a 100644
--- a/configure.in
+++ b/configure.in
@@ -3824,24 +3824,6 @@ AC_SUBST(HAVE_GCC_VISIBILITY_FEATURE)
AC_SUBST(HAVE_GCC_VISIBILITY_BROKEN)
dnl ===================================================================
-dnl gcc DWARF-4 support (smaller debug info)
-dnl ===================================================================
-if test "$GCC" = "yes"; then
- AC_MSG_CHECKING([whether $CC supports -gdwarf-4])
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror -gdwarf-4"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],[ HAVE_GCC_DWARF_4=TRUE ],[])
- CFLAGS=$save_CFLAGS
- if test "$HAVE_GCC_DWARF_4" = "TRUE"; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- fi
-fi
-
-AC_SUBST(HAVE_GCC_DWARF_4)
-
-dnl ===================================================================
dnl allocator
dnl ===================================================================
AC_MSG_CHECKING([which memory allocator to use])