summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJames C <james.from.wellington@gmail.com>2011-12-20 02:15:08 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2011-12-20 02:15:40 -0600
commitcf33de27eb5e981d8a1fa76f6a9d72ce7174f10d (patch)
treeeacf6ce12a7c2b1ecf804fe230096525cdb4fce8 /configure.in
parentb71919511f7748af7c69a2d2da4e937777af7eb7 (diff)
Fix gmake detection for MacOSX
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 84d7b506501d..120ed1ffb10a 100644
--- a/configure.in
+++ b/configure.in
@@ -2705,7 +2705,19 @@ if test "$_make_longver" -ge "038200" ; then
elif test "$_make_longver" -ge "038100" ; then
AC_MSG_RESULT([$GNUMAKE $_make_version])
AC_MSG_CHECKING([for GNU make bug 20033])
- TESTGMAKEBUG20033=`mktemp -d`
+ dnl
+ dnl FIXME: mktemp takes different arguments on different platforms:
+ dnl http://stackoverflow.com/questions/2792675/how-portable-is-mktemp1
+ dnl
+ dnl -t means either 'use $TMPDIR' (OK) or 'the following is a template'.
+ dnl and without 'the following is a template', a following template
+ dnl is allowed, so this *may* work on *most* platforms
+ dnl
+ TESTGMAKEBUG20033=`mktemp -d -t MakefileXX`
+ SHA1SUM=sha1sum
+ if test "$_os" = "Darwin"; then
+ SHA1SUM=shasum
+ fi
cat > $TESTGMAKEBUG20033/Makefile << EOF
A := \$(wildcard *.a)
@@ -2728,7 +2740,7 @@ define d2
endef
%.b : %.a
- \$(eval CHECKSUM := \$(word 1,\$(shell cat \$^ | sha1sum))) \$(if \$(wildcard \$(CACHEDIR)/\$(CHECKSUM)),\
+ \$(eval CHECKSUM := \$(word 1,\$(shell cat \$^ | $SHA1SUM))) \$(if \$(wildcard \$(CACHEDIR)/\$(CHECKSUM)),\
\$(call d1,\$(CHECKSUM)),\
\$(call d2,\$(CHECKSUM)))
EOF