summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2011-12-01 13:39:09 +0100
committerDavid Tardon <dtardon@redhat.com>2011-12-05 15:11:52 +0100
commitadb110517139252962b1ccf8f9230a4981a9573a (patch)
tree2a6ac2d1b9069d6c6e551ccfa72fc60cd019e987 /configure.in
parent85c6244b85b29c1d2bb9d89b62e9512dd65378b5 (diff)
set up CFLAGS/LIBS for gtk print dialog in configure
The dialog is built for gtk 2.0 if the version present at the system is at least 2.10.0 and always for gtk 3.0.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index cf0d3cb013d1..d50a9eb42b4f 100644
--- a/configure.in
+++ b/configure.in
@@ -7007,7 +7007,7 @@ if test "x$enable_gtk3" = "xyes"; then
if test "$with_system_cairo" != yes; then
echo "System cairo required for gtk3 support, please use --with-system-cairo"
fi
- PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.2 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
+ PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.2 gtk+-unix-print-3.0 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
if test "x$ENABLE_GTK3" = "xTRUE"; then
R="gtk3"
else
@@ -7099,6 +7099,11 @@ if test "$test_gtk" = "yes"; then
[ ENABLE_SYSTRAY_GTK="" ])
fi
+ AC_MSG_CHECKING([whether to enable Gtk print dialog support])
+ PKG_CHECK_MODULES([GTK_PRINT], [gtk+-unix-print-2.0 >= 2.10.0],
+ [ENABLE_GTK_PRINT="TRUE"],
+ [ENABLE_GTK_PRINT=""])
+
AC_MSG_CHECKING([whether to enable DBUS support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_dbus" = "yes"; then
ENABLE_DBUS="TRUE"
@@ -7130,6 +7135,9 @@ AC_SUBST(GTHREAD_CFLAGS)
AC_SUBST(GTHREAD_LIBS)
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
+AC_SUBST([ENABLE_GTK_PRINT])
+AC_SUBST([GTK_PRINT_CFLAGS])
+AC_SUBST([GTK_PRINT_LIBS])
PKG_CHECK_MODULES( LIBPNG, libpng, ENABLE_QUICKSTART_LIBPNG="TRUE", ENABLE_QUICKSTART_LIBPNG="" )
AC_SUBST(LIBPNG_LIBS)