summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThorsten Behrens <tbehrens@suse.com>2011-12-06 17:27:05 +0100
committerThorsten Behrens <tbehrens@suse.com>2011-12-06 17:28:11 +0100
commit88a4a8d997921309a7886ed0d1dc383ee3c2f767 (patch)
tree5fc956b3896956543d5c415575d94b9e7c6372b0 /configure.in
parentd57887eaad534ca51fc4975918fab66b2f93633d (diff)
GdkPrinter seems optional on Gtk3, too
Added necessary configure magic & conditional compiles for that.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8b23b1f7bfde..1d2cde1aa033 100644
--- a/configure.in
+++ b/configure.in
@@ -7003,20 +7003,32 @@ R=""
GTK3_CFLAGS=""
GTK3_LIBS=""
ENABLE_GTK3=""
+GTK3_PRINT_CFLAGS=""
+GTK3_PRINT_LIBS=""
+ENABLE_GTK3_PRINT=""
if test "x$enable_gtk3" = "xyes"; then
if test "$with_system_cairo" != yes; then
echo "System cairo required for gtk3 support, please use --with-system-cairo"
fi
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.2 gtk+-unix-print-3.0 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
+
if test "x$ENABLE_GTK3" = "xTRUE"; then
R="gtk3"
else
AC_MSG_ERROR([gtk3 libraries of the correct versions, not found])
fi
+
+ AC_MSG_CHECKING([whether to enable Gtk3 print dialog support])
+ PKG_CHECK_MODULES([GTK3_PRINT], [gtk+-unix-print-3.0 >= 3.2.0],
+ [ENABLE_GTK3_PRINT="TRUE"],
+ [ENABLE_GTK3_PRINT=""])
fi
AC_SUBST(GTK3_LIBS)
AC_SUBST(GTK3_CFLAGS)
AC_SUBST(ENABLE_GTK3)
+AC_SUBST(GTK3_PRINT_CFLAGS)
+AC_SUBST(GTK3_PRINT_LIBS)
+AC_SUBST(ENABLE_GTK3_PRINT)
AC_MSG_CHECKING([which VCLplugs shall be built])
ENABLE_GTK=""