summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLionel Elie Mamane <lionel@mamane.lu>2011-12-01 22:21:43 +0100
committerLionel Elie Mamane <lionel@mamane.lu>2011-12-01 22:56:07 +0100
commit74283f6976c727233ca330a1e9bf6ee4f52f86c5 (patch)
tree2fe202c6434c081f1c39c2963a391fd4c3eced0a /configure.in
parentc351b1e19f1b1207949b70386640dc06ef0144ad (diff)
External PostgreSQL: automatically search MacOS-specific paths
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f75aeb3b3dc5..796c5f12cecc 100644
--- a/configure.in
+++ b/configure.in
@@ -5407,7 +5407,13 @@ if test "x$enable_ext_postgresql_sdbc" = "xyes" -a "x$enable_extension_integrati
if test "$with_system_postgresql" = "yes"; then
AC_MSG_RESULT([external PostgreSQL])
SYSTEM_POSTGRESQL=YES
- AC_PATH_PROG(PGCONFIG, pg_config)
+ if test "$_os" = Darwin; then
+ supp_path=''
+ for d in /Library/PostgreSQL/9.*/bin; do
+ pg_supp_path="$PATH_SEPARATOR$d$pg_supp_path"
+ done
+ fi
+ AC_PATH_PROG(PGCONFIG, pg_config, ,$PATH$pg_supp_path)
if test -z "$PGCONFIG"; then
AC_MSG_ERROR([pg_config needed; set PGCONFIG if not in PATH])
fi