summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThorsten Behrens <tbehrens@suse.com>2011-12-08 12:03:38 +0100
committerThorsten Behrens <tbehrens@suse.com>2011-12-08 12:22:57 +0100
commit456ec763d77a238967b866e2f90d1052626c2fdb (patch)
tree69414aa4f76ae410f220233c2f45c27be9fb2e83 /configure.in
parent704ee5bc859499f5fe824f66f9607b554c135c66 (diff)
Rework yacc rule for gcc platforms.
Generalized the OSX ppc workaround for ancient bison versions, factored out for all gcc platforms. Put bison version detection into configure accordingly, to switch on that, and not on platform.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9cd71ede0544..1c9a08d965fd 100644
--- a/configure.in
+++ b/configure.in
@@ -6790,6 +6790,7 @@ dnl ***************************************
dnl Checking for bison and flex
dnl ***************************************
AC_PATH_PROG(BISON, bison)
+ANCIENT_BISON="NO"
if test -z "$BISON"; then
AC_MSG_ERROR([no bison found in \$PATH, install it])
else
@@ -6807,7 +6808,12 @@ else
else
AC_MSG_ERROR([failed ($BISON $_bison_version need 1.875+ (or 1.75 and older))])
fi
+ if test "$_bison_longver" -lt 2000; then
+ ANCIENT_BISON="YES"
+ fi
fi
+AC_SUBST(ANCIENT_BISON)
+
AC_PATH_PROG(FLEX, flex)
if test -z "$FLEX"; then
AC_MSG_ERROR([no flex found in \$PATH, install it])