summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThorsten Behrens <tbehrens@suse.com>2011-12-06 18:08:18 +0100
committerThorsten Behrens <tbehrens@suse.com>2011-12-06 18:08:18 +0100
commit1a81ca45ea9192013b4e5bdb2eb769a75b56dea5 (patch)
treebd3bc1ad42bf37f8b1b7f12a1afbcde4dc7b4740 /configure.in
parenta25a01361e891b1570e3e4e338d88f66889f3142 (diff)
Revert "GdkPrinter seems optional on Gtk3, too"
This reverts commit 88a4a8d997921309a7886ed0d1dc383ee3c2f767. Sorry, seemed to be an intermittent local problem.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 1d2cde1aa033..8b23b1f7bfde 100644
--- a/configure.in
+++ b/configure.in
@@ -7003,32 +7003,20 @@ R=""
GTK3_CFLAGS=""
GTK3_LIBS=""
ENABLE_GTK3=""
-GTK3_PRINT_CFLAGS=""
-GTK3_PRINT_LIBS=""
-ENABLE_GTK3_PRINT=""
if test "x$enable_gtk3" = "xyes"; then
if test "$with_system_cairo" != yes; then
echo "System cairo required for gtk3 support, please use --with-system-cairo"
fi
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.2 gtk+-unix-print-3.0 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
-
if test "x$ENABLE_GTK3" = "xTRUE"; then
R="gtk3"
else
AC_MSG_ERROR([gtk3 libraries of the correct versions, not found])
fi
-
- AC_MSG_CHECKING([whether to enable Gtk3 print dialog support])
- PKG_CHECK_MODULES([GTK3_PRINT], [gtk+-unix-print-3.0 >= 3.2.0],
- [ENABLE_GTK3_PRINT="TRUE"],
- [ENABLE_GTK3_PRINT=""])
fi
AC_SUBST(GTK3_LIBS)
AC_SUBST(GTK3_CFLAGS)
AC_SUBST(ENABLE_GTK3)
-AC_SUBST(GTK3_PRINT_CFLAGS)
-AC_SUBST(GTK3_PRINT_LIBS)
-AC_SUBST(ENABLE_GTK3_PRINT)
AC_MSG_CHECKING([which VCLplugs shall be built])
ENABLE_GTK=""