summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@novell.com>2011-05-17 15:23:40 +0100
committerFridrich Štrba <fridrich.strba@bluewin.ch>2011-05-17 16:40:09 +0200
commited1b699f659978ea268cec6e385d5f42027b58cc (patch)
tree4b72a72834f43698382e7d6dfff23f6a943c2cd8 /configure.in
parent7d9a21d21d6e089b84659a3c8c1b15178937646e (diff)
fix ENABLE_QUICKSTART_LIBPNG handling fdo#36497
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in22
1 files changed, 15 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 0705312c7550..325766885a1e 100755
--- a/configure.in
+++ b/configure.in
@@ -353,6 +353,13 @@ AC_ARG_ENABLE(kde4,
both KDE3 and KDE4.]),
,)
+AC_ARG_ENABLE(unix-qstart-libpng,
+ AS_HELP_STRING([--disable-unix-qstart-libpng],
+ [On UNIX systems, we have a faster splash app, that can use libpng to
+ render its splash, if we can safely link to the system libpng then
+ enabling this is a good idea (ie. for Linux Distro packaging).]),
+,enable_unix_libpng=yes)
+
AC_ARG_ENABLE(binfilter,
AS_HELP_STRING([--enable-binfilter],
[Enable legacy binary file formats filters build.]),
@@ -6136,16 +6143,17 @@ AC_SUBST(ENABLE_SYSTRAY_GTK)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
-AC_ARG_ENABLE(unix-qstart,
- AS_HELP_STRING([--disable-unix-qstart],
- [On UNIX systems, we can enable a faster splash app that accelerates
- startup, if we can link to the system libpng, use this if you are
- a Linux Distro packager.]),
-,enable_unix_quickstarter=yes)
-
PKG_CHECK_MODULES( LIBPNG, libpng, ENABLE_QUICKSTART_LIBPNG="TRUE", ENABLE_QUICKSTART_LIBPNG="" )
AC_SUBST(LIBPNG_LIBS)
AC_SUBST(LIBPNG_CFLAGS)
+
+AC_MSG_CHECKING([whether to enable libpng linking in quickstarter])
+if test "x$enable_unix_libpng" = "xyes"; then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+ ENABLE_QUICKSTART_LIBPNG=""
+fi
AC_SUBST(ENABLE_QUICKSTART_LIBPNG)
ENABLE_BROFFICE=""