summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKalman Szalai - KAMI <kami911@gmail.com>2011-05-08 10:25:25 +0200
committerFridrich Štrba <fridrich.strba@bluewin.ch>2011-05-12 12:22:13 +0200
commitb04faf6398cc8bf899fcd096cbd682a76470e85c (patch)
tree4a436b75155ff7d62e8ab87a5420ece9def6c202 /configure.in
parentda487f88506385d6ff3ea483580a2627dae2141c (diff)
Fix Ligthproof extension integration
* Fix configure and download support * Extension naming scheme is: <md5>-<extension-name>_<version>.oxt - Renamed extensions * Rename extension version number in download script and scp2 module Signed-off-by: Fridrich Štrba <fridrich.strba@bluewin.ch>
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 73e86aa6da3f..81ed085d6b0c 100755
--- a/configure.in
+++ b/configure.in
@@ -7106,7 +7106,7 @@ if test "z$enable_ext_lightproof" = "z" -o "z$enable_ext_lightproof" = "zno" ; t
AC_MSG_RESULT([no integration])
else
SCPDEFS="$SCPDEFS -DWITH_EXTENSION_LIGHTPROOF"
- lightproof_supported_langs="hu"
+ lightproof_supported_langs="en-US hu"
if test "z$enable_ext_lightproof" = "zyes" ; then
wanted_lightproof="$lightproof_supported_langs"
else
@@ -7119,15 +7119,23 @@ else
done
fi
LIGHTPROOF_LANG=
+ LIGHTPROOF_HU_PACK=
+ LIGHTPROOF_EN_US_PACK=
# check whether the langs are requested at all
for lang in $wanted_lightproof ; do
if test "$with_lang" = "ALL" -o -n "`echo $with_lang | grep "$lang"`" ; then
LIGHTPROOF_LANG="$LIGHTPROOF_LANG $lang"
+ case $lang in
+ "hu") LIGHTPROOF_HU_PACK="324ddcb9ef45c3bc055fcc002bc4e556-lightproof-hu_1.2.oxt";;
+ "en-US") LIGHTPROOF_EN_US_PACK="942541da5f5498214518c8b459ae4524-lightproof-en-US_0.1.oxt";;
+ esac
fi
done
AC_MSG_RESULT([$LIGHTPROOF_LANG])
fi
AC_SUBST(LIGHTPROOF_LANG)
+AC_SUBST(LIGHTPROOF_HU_PACK)
+AC_SUBST(LIGHTPROOF_EN_US_PACK)
dnl ===================================================================
dnl Test whether to include Watch Window extension
@@ -7196,7 +7204,7 @@ else
AC_MSG_RESULT([yes])
BUILD_TYPE="$BUILD_TYPE CT2N"
SCPDEFS="$SCPDEFS -DWITH_EXTENSION_CT2N"
- CT2N_EXTENSION_PACK="451ccf439a36a568653b024534669971-ConvertTextToNumber-1.3.2.oxt"
+ CT2N_EXTENSION_PACK="451ccf439a36a568653b024534669971-ConvertTextToNumber_1.3.2.oxt"
fi
AC_SUBST(CT2N_EXTENSION_PACK)
@@ -7224,7 +7232,7 @@ if test "z$enable_ext_hunart" = "z" -o "z$enable_ext_hunart" = "zno" ; then
else
AC_MSG_RESULT([yes])
SCPDEFS="$SCPDEFS -DWITH_EXTENSION_HUNART"
- HUNART_EXTENSION_PACK="b632bdd25649cc4067bcb410bae23d2b-hunart-0.3.oxt"
+ HUNART_EXTENSION_PACK="b632bdd25649cc4067bcb410bae23d2b-hunart_0.3.oxt"
fi
AC_SUBST(HUNART_EXTENSION_PACK)
@@ -7238,7 +7246,7 @@ if test "z$enable_ext_typo" = "z" -o "z$enable_ext_typo" = "zno" ; then
else
AC_MSG_RESULT([yes])
SCPDEFS="$SCPDEFS -DWITH_EXTENSION_TYPO"
- TYPO_EXTENSION_PACK="9d60b6cfa3ef1926848710bbcd11115b-typo-0.4.2.oxt"
+ TYPO_EXTENSION_PACK="9d60b6cfa3ef1926848710bbcd11115b-typo_0.4.2.oxt"
fi
AC_SUBST(TYPO_EXTENSION_PACK)