summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2011-04-05 12:26:12 +0200
committerPetr Mladek <pmladek@suse.cz>2011-04-05 12:26:12 +0200
commit691961e7f65c336b718fc01f25a5b6d9b6df1c14 (patch)
tree1d33f09025e1eccbdc09c0f114de13efa434b6a7 /configure.in
parentf958c05128fb8fe3d833f62d488b03b09c4f7abe (diff)
make sure that the system po2oo support --skipsource option
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index a49bd885f8e7..a7fdca702629 100755
--- a/configure.in
+++ b/configure.in
@@ -4165,6 +4165,9 @@ dnl Check for system translate-toolkit
dnl ===================================================================
AC_MSG_CHECKING([which translate-toolkit to use])
if test "$with_system_translate_toolkit" = "yes" ; then
+ AC_MSG_RESULT([system])
+ SYSTEM_TRANSLATE_TOOLKIT=YES
+
AC_PATH_PROGS(OO2PO, oo2po)
if test -z "$OO2PO"; then
AC_MSG_ERROR([install translate-toolkit or use --without-system-translate-toolkit])
@@ -4174,9 +4177,11 @@ if test "$with_system_translate_toolkit" = "yes" ; then
if test -z "$PO2OO"; then
AC_MSG_ERROR([install translate-toolkit or use --without-system-translate-toolkit])
fi
-
- AC_MSG_RESULT([system])
- SYSTEM_TRANSLATE_TOOLKIT=YES
+
+ $PO2OO --help | grep -q '\-\-skipsource'
+ if test $? -ne 0 ; then
+ AC_MSG_ERROR([$PO2OO does not support --skipsource; use translate-toolkit >= 1.9 or use --without-system-translate-toolkit])
+ fi
else
AC_MSG_RESULT([internal])
SYSTEM_TRANSLATE_TOOLKIT=NO