summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-06-03 12:33:09 +0200
committerDavid Tardon <dtardon@redhat.com>2012-06-03 12:44:02 +0200
commit09cd5c460704ddd99669a61ae335bfb2ce357140 (patch)
treef6ed94d2e14be0cc79aba1188f472cd328700afb /configure.in
parent38b32390cd39c9179f1fb36f2523a2343e69646d (diff)
do not check for win-specific stuff on mingw
Change-Id: I8316e1ce35d059938da35651c0fa1412b8648a7d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 12 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 911588f4ce55..ba797fda04e3 100644
--- a/configure.in
+++ b/configure.in
@@ -2523,7 +2523,7 @@ AC_SUBST(MAC_OS_X_VERSION_MAX_ALLOWED)
dnl ===================================================================
dnl Windows specific tests and stuff
dnl ===================================================================
-if test "$_os" = "WINNT"; then
+if test "$_os" = "WINNT" -a "$WITH_MINGW" != yes; then
dnl Set the CL_X64 variable if we are building a 64-bit LibreOffice.
AC_MSG_CHECKING([whether to build a 64-bit LibreOffice])
if test "$enable_cl_x64" = "" -o "$enable_cl_x64" = "no"; then
@@ -2533,7 +2533,6 @@ if test "$_os" = "WINNT"; then
CL_X64="TRUE"
AC_MSG_RESULT([yes])
fi
- AC_SUBST(CL_X64)
AC_MSG_CHECKING([whether to use DirectX])
if test "$enable_directx" = "yes" -o "$enable_directx" = ""; then
@@ -2543,7 +2542,6 @@ if test "$_os" = "WINNT"; then
ENABLE_DIRECTX=""
AC_MSG_RESULT([no])
fi
- AC_SUBST(ENABLE_DIRECTX)
AC_MSG_CHECKING([whether to use ActiveX])
if test "$enable_activex" = "yes" -o "$enable_activex" = "TRUE" -o "$enable_activex" = ""; then
@@ -2554,27 +2552,27 @@ if test "$_os" = "WINNT"; then
DISABLE_ACTIVEX="TRUE"
AC_MSG_RESULT([no])
fi
- AC_SUBST(DISABLE_ACTIVEX)
AC_MSG_CHECKING([whether to use ATL])
- if test "$enable_atl" = "yes" -o "$enable_atl" = "TRUE"; then
+ if test "$enable_atl" = "yes" -o "$enable_atl" = "TRUE" -o "$enable_atl" = ""; then
DISABLE_ATL=""
AC_MSG_RESULT([yes])
- elif test "$enable_atl" = ""; then
- if test "$WITH_MINGW" = "yes"; then
- DISABLE_ATL="TRUE"
- AC_MSG_RESULT([no])
- else
- DISABLE_ATL=""
- AC_MSG_RESULT([yes])
- fi
else
DISABLE_ATL="TRUE"
AC_MSG_RESULT([no])
fi
- AC_SUBST(DISABLE_ATL)
+else
+ CL_X64=""
+ ENABLE_DIRECTX=""
+ DISABLE_ACTIVEX="TRUE"
+ DISABLE_ATL="TRUE"
fi
+AC_SUBST(CL_X64)
+AC_SUBST(ENABLE_DIRECTX)
+AC_SUBST(DISABLE_ACTIVEX)
+AC_SUBST(DISABLE_ATL)
+
dnl ===================================================================
dnl Test the gcc version
dnl ===================================================================