summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@openoffice.org>2010-06-22 18:07:30 +0200
committerRene Engelhard <rene@openoffice.org>2010-06-22 18:07:30 +0200
commita80e89c5529e2cb5b38b0c6b046ef4d3585437e1 (patch)
tree9e0a95562f596c59ae5476859dc03316e4364d30 /configure.in
parent6c95e802bcb213e2611a164e4d6e16ec2be73bf7 (diff)
configure25: #i99063# heck if rpm(build) can actually build
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a3431fc0f0c2..e8854c685222 100644
--- a/configure.in
+++ b/configure.in
@@ -3331,9 +3331,11 @@ msi - Windows .msi
done
if test -z "$RPM" ; then
AC_MSG_ERROR([not found])
- else
+ elif "$RPM" --usage 2>&1 | $EGREP -- -bb >/dev/null; then
RPM_PATH=`which $RPM`
- AC_MSG_RESULT([$RPM_PATH])
+ AC_MSG_RESULT([$RPM_PATH])
+ else
+ AC_MSG_ERROR([cannot build packages. Try installing rpmbuild.])
fi
fi
if echo "$PKGFORMAT" | $EGREP deb 2>&1 >/dev/null; then