summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2011-01-05 19:27:15 +0100
committerPetr Mladek <pmladek@suse.cz>2011-01-07 18:38:45 +0100
commit961abfc6f24f862d9f5dd79441eeebe9ecba1e61 (patch)
tree20a3e9f805de4488b499f967ecae87cd826bbb67 /configure.in
parent2867342bbb53167932fce40834eb2e9ee1f8a2c1 (diff)
Fix distro specific about intro hadling
I guess that nobody uses more alternative branding pictures. It was implemented for SLED10-GM and it is not longer needed there. So I renamed: --with-intro-bitmaps to --with-intro-bitmap --with-about-bitmaps to --with-about-bitmap and INTRO_BITMAPS to INTRO_BITMAPS ABOUT_BITMAPS to ABOUT_BITMAP Also .png file format is requred instead of .bmp now. Signed off by KAMI.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in68
1 files changed, 28 insertions, 40 deletions
diff --git a/configure.in b/configure.in
index 409c756bc77c..32c4601e3aff 100644
--- a/configure.in
+++ b/configure.in
@@ -1091,20 +1091,18 @@ AC_ARG_WITH(dict,
Usage: --with-dict=ENGB,ENUS,ITIT
],,)
-AC_ARG_WITH(intro-bitmaps,
-[ --with-intro-bitmaps Prefer the specified intro bitmaps over the
- the default one. Can be more than one (separated by
- commas), the order means priority of fallback if the
- first does not exist (in the installed tree).
+AC_ARG_WITH(intro-bitmap,
+[ --with-intro-bitmap Prefer the specified intro bitmap over the
+ the default one.
- Usage: --with-intro-bitmaps=/path/my_ooo_intro.bmp
+ Usage: --with-intro-bitmap=/path/my_ooo_intro.png
],,)
-AC_ARG_WITH(about-bitmaps,
-[ --with-about-bitmaps Similarly to --with-intro-bitmaps, this allows
- specification of bitmaps for the About box.
+AC_ARG_WITH(about-bitmap,
+[ --with-about-bitmap Similarly to --with-intro-bitmap, this allows
+ specification of bitmap for the About box.
- Usage: --with-about-bitmaps=/path/my_ooo_about.bmp
+ Usage: --with-about-bitmap=/path/my_ooo_about.png
],,)
AC_ARG_WITH(vendor,
@@ -7779,43 +7777,33 @@ else
fi
AC_SUBST(WITH_DICT)
-AC_MSG_CHECKING([for additional 'intro' bitmaps])
-INTRO_BITMAPS=
-if test -z "$with_intro_bitmaps" -o "$with_intro_bitmaps" = "no" ; then
- INTRO_BITMAPS=
+AC_MSG_CHECKING([for another 'intro' bitmap])
+INTRO_BITMAP=
+if test -z "$with_intro_bitmap" -o "$with_intro_bitmap" = "no" ; then
+ INTRO_BITMAP=
AC_MSG_RESULT([none])
else
- for bitmap in `echo $with_intro_bitmaps | tr ',' ' '` ; do
- case "$bitmap" in
- *.bmp) ;;
- *) bitmap= ; AC_MSG_WARN([Intro bitmaps should be .bmp files!]) ;;
- esac
- if test -n "$bitmap" ; then
- INTRO_BITMAPS="$INTRO_BITMAPS $bitmap"
- fi
- done
- AC_MSG_RESULT([$INTRO_BITMAPS])
+ case "$with_intro_bitmap" in
+ *.png) INTRO_BITMAP="$with_intro_bitmap" ;;
+ *) AC_MSG_WARN([Intro bitmap should be a .png file!]) ;;
+ esac
+ AC_MSG_RESULT([$INTRO_BITMAP])
fi
-AC_SUBST(INTRO_BITMAPS)
+AC_SUBST(INTRO_BITMAP)
-AC_MSG_CHECKING([for additional 'about' bitmaps])
-ABOUT_BITMAPS=
-if test -z "$with_about_bitmaps" -o "$with_about_bitmaps" = "no" ; then
- ABOUT_BITMAPS=
+AC_MSG_CHECKING([for another 'about' bitmap])
+ABOUT_BITMAP=
+if test -z "$with_about_bitmap" -o "$with_about_bitmap" = "no" ; then
+ ABOUT_BITMAP=
AC_MSG_RESULT([none])
else
- for bitmap in `echo $with_about_bitmaps | tr ',' ' '` ; do
- case "$bitmap" in
- *.bmp) ;;
- *) bitmap= ; AC_MSG_WARN([About bitmaps should be .bmp files!]) ;;
- esac
- if test -n "$bitmap" ; then
- ABOUT_BITMAPS="$ABOUT_BITMAPS $bitmap"
- fi
- done
- AC_MSG_RESULT([$ABOUT_BITMAPS])
+ case "$with_about_bitmap" in
+ *.png) ABOUT_BITMAP="$with_about_bitmap" ;;
+ *) AC_MSG_WARN([About bitmap should be a .png file!]) ;;
+ esac
+ AC_MSG_RESULT([$ABOUT_BITMAP])
fi
-AC_SUBST(ABOUT_BITMAPS)
+AC_SUBST(ABOUT_BITMAP)
OOO_VENDOR=
AC_MSG_CHECKING([for vendor])