summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2011-02-18 09:34:44 +0100
committerDavid Tardon <dtardon@redhat.com>2011-02-18 09:47:50 +0100
commit657710a76da373c9b120081e068465e44d550bfd (patch)
treee8100c6cb8ce8ce5c86e473faf7935b4ef893d31 /configure.in
parent399a30d20ee6b806ac3b9b376d5ca014bfa75a50 (diff)
configure inclusion/exclusion of scripting providers
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in51
1 files changed, 51 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 45a22cd435e9..20b30514567f 100755
--- a/configure.in
+++ b/configure.in
@@ -83,6 +83,21 @@ AC_ARG_ENABLE(ext-report-builder,
[Enables the build of the Report Builder extension.]),
,)
+AC_ARG_ENABLE(ext-scripting-beanshell,
+ AS_HELP_STRING([--enable-ext-scripting-beanshell],
+ [Enables support for scripts in BeanShell]),
+,)
+
+AC_ARG_ENABLE(ext-scripting-javascript,
+ AS_HELP_STRING([--enable-ext-scripting-javascript],
+ [Enables support for scripts in JavaScript]),
+,)
+
+AC_ARG_ENABLE(ext-scripting-python,
+ AS_HELP_STRING([--enable-ext-scripting-python],
+ [Enables support for scripts in Python]),
+,)
+
AC_ARG_ENABLE(ext-typo,
AS_HELP_STRING([--enable-ext-typo],
[Enables the Typography Toolbar extension.]),
@@ -6682,6 +6697,42 @@ AC_SUBST(COMMONS_LANG_JAR)
AC_SUBST(COMMONS_HTTPCLIENT_JAR)
AC_SUBST(COMMONS_LOGGING_JAR)
+# scripting provider for BeanShell extension?
+AC_MSG_CHECKING([whether to build extension for support of scripts in BeanShell])
+AS_IF([test "x$enable_ext_scripting_beanshell" = "xyes"], [
+ AC_MSG_RESULT([yes])
+ ENABLE_SCRIPTING_BEANSHELL=YES
+],[
+ AC_MSG_RESULT([no])
+ ENABLE_SCRIPTING_BEANSHELL=NO
+ SCPDEFS="$SCPDEFS -DWITHOUT_EXTENSION_SCRIPTING_BEANSHELL"
+])
+AC_SUBST(ENABLE_SCRIPTING_BEANSHELL)
+
+# scripting provider for JavaScript extension?
+AC_MSG_CHECKING([whether to build extension for support of scripts in JavaScript])
+AS_IF([test "x$enable_ext_scripting_javascript" = "xyes"], [
+ AC_MSG_RESULT([yes])
+ ENABLE_SCRIPTING_JAVASCRIPT=YES
+],[
+ AC_MSG_RESULT([no])
+ ENABLE_SCRIPTING_JAVASCRIPT=NO
+ SCPDEFS="$SCPDEFS -DWITHOUT_EXTENSION_SCRIPTING_JAVASCRIPT"
+])
+AC_SUBST(ENABLE_SCRIPTING_JAVASCRIPT)
+
+# scripting provider for Python extension?
+AC_MSG_CHECKING([whether to build extension for support of scripts in Python])
+AS_IF([test "x$enable_ext_scripting_python" = "xyes"], [
+ AC_MSG_RESULT([yes])
+ ENABLE_SCRIPTING_PYTHON=YES
+],[
+ AC_MSG_RESULT([no])
+ ENABLE_SCRIPTING_PYTHON=NO
+ SCPDEFS="$SCPDEFS -DWITHOUT_EXTENSION_SCRIPTING_PYTHON"
+])
+AC_SUBST(ENABLE_SCRIPTING_PYTHON)
+
dnl ===================================================================
dnl Check whether the Qt3 and KDE3 libraries are available.
dnl ===================================================================