summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-04-10 12:48:41 +0200
committerAndras Timar <andras.timar@collabora.com>2014-04-16 17:07:18 +0200
commitc086d5cf8ae47c5f6129f04dbe522fc6ecca169c (patch)
treeb01364af147e9d5fa5e1071a0cefbe4d6857e2c0 /configure.ac
parent78f36104dc1be3d0243090ee4d5daffcde9b3f25 (diff)
fdo#75376: configure: disable LTO by default for MSVC too
MSVC 2010 LTO triggers some bug in painting Writer documents; unfortunately it's not possible to put a VCVER check in there to enable LTO by default only for MSVC2012 because the compiler detection actually uses the ENABLE_LTO value. Change-Id: I29ecdd552d8a8bbd673a844e6bf0c938a98825c2 (cherry picked from commit 0d8e3a145901ab0124d40d33a50e2de28dc0c8ab) Reviewed-on: https://gerrit.libreoffice.org/8918 Tested-by: Norbert Thiebaud <nthiebaud@gmail.com> Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 6ae390c0f7af..64fa5dbb640c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2530,12 +2530,6 @@ COMPATH=`echo $COMPATH | $SED "s@/[[Bb]][[Ii]][[Nn]]\\\$@@"`
# Set the ENABLE_LTO variable
# ===================================================================
AC_MSG_CHECKING([whether to use link-time optimization])
-if test $_os = WINNT -a "$WITH_MINGW" != yes -a -z "$enable_lto" -a \
- \( -z "$enable_dbgutil" -o "$enable_dbgutil" = no \) -a \
- \( -z "$enable_debug" -o "$enable_debug" = no \); then
- # Turn on LTO for MSVC when optimising unless told not to
- enable_lto=yes
-fi
if test -n "$enable_lto" -a "$enable_lto" != "no"; then
ENABLE_LTO="TRUE"
AC_MSG_RESULT([yes])
@@ -3595,6 +3589,11 @@ if test "$_os" = "WINNT"; then
100)
COMEX=13
WINDOWS_SDK_ACCEPTABLE_VERSIONS="7.1A 7.1 7.0A 6.0A"
+ if test "$ENABLE_LTO" = TRUE; then
+
+ AC_MSG_WARN([LTO is known to cause problems with MSVC 2010])
+ add_warning "LTO is known to cause problems with MSVC 2010"
+ fi
;;
110)
COMEX=14