summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Weghorn <m.weghorn@posteo.de>2022-04-21 07:52:20 +0200
committerMichael Weghorn <m.weghorn@posteo.de>2022-04-21 11:15:43 +0200
commitb548507896f9b1fef606e5d5329c6283436a592c (patch)
tree7554236747f205bdce7fdfbe509f153df3ebf62c /configure.ac
parent85aa57359befd7a21b3fdf36f2b362f50495f77c (diff)
android: Drop obsolete build tools version check from configure.ac
`build.gradle` no longer contains a specific `buildToolsVersion` since commit a93770e6d0d2fcc5a2eefbed546acee055833fd4 Date: Fri Mar 6 12:16:24 2020 +0100 android: Update gradle The previous version e.g. did not support building Android App Bundles yet. Drop explicit 'buildToolsVersion', as suggested in the warning during build: > WARNING: The specified Android SDK Build Tools version (27.0.3) is ignored, > as it is below the minimum supported version (28.0.3) for Android Gradle > Plugin 3.6.1. > Android SDK Build Tools 28.0.3 will be used. > To suppress this warning, remove "buildToolsVersion '27.0.3'" from your build.gradle > file, as each version of the Android Gradle Plugin now has a default > version of the build tools. so the sed expression in configure.ac was evaluating to an empty string and only the existence of `"$ANDROID_SDK_DIR/build-tools/` was checked. As mentioned in a93770e6d0d2fcc5a2eefbed546acee055833fd4, each version of the Android Gradle Plugin now has a default version of the build tools. It takes care of downloading and installing that one as necessary. Change-Id: Ic8528c5dc238dccb35ccf215945ef935e8c3a89c Reviewed-on: https://gerrit.libreoffice.org/c/core/+/133238 Tested-by: Jenkins Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index a5ca807b9036..f27b14676a4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1243,16 +1243,6 @@ if test "$_os" = "Android" ; then
elif test ! -d "$ANDROID_SDK_DIR/platforms"; then
AC_MSG_ERROR([the --with-android-sdk option does not point to an Android SDK])
fi
-
- BUILD_TOOLS_VERSION=`$SED -n -e 's/.*buildToolsVersion "\(.*\)"/\1/p' $SRC_ROOT/android/source/build.gradle`
- if test ! -d "$ANDROID_SDK_DIR/build-tools/$BUILD_TOOLS_VERSION"; then
- AC_MSG_WARN([android build-tools $BUILD_TOOLS_VERSION not found - install with
- $ANDROID_SDK_DIR/tools/android update sdk -u --all --filter build-tools-$BUILD_TOOLS_VERSION
- or adjust change $SRC_ROOT/android/source/build.gradle accordingly])
- add_warning "android build-tools $BUILD_TOOLS_VERSION not found - install with"
- add_warning " $ANDROID_SDK_DIR/tools/android update sdk -u --all --filter build-tools-$BUILD_TOOLS_VERSION"
- add_warning "or adjust $SRC_ROOT/android/source/build.gradle accordingly"
- fi
fi
if test "$_os" = "AIX"; then