summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-12-18 10:59:46 +0100
committerStephan Bergmann <sbergman@redhat.com>2019-12-18 13:54:27 +0100
commit97d736d27435fb26d5609000f77bd79ece08572e (patch)
tree29ffd1c3fb18590468a69ce92a4e0d2f991982f2 /configure.ac
parentc85588548bb016eb88247de75e303be2585023a6 (diff)
Fix typos concerning the __cxa_exception check
...introduced with 069506bcb0ee4005b01c22095ed427b96b553c98 "Use config_cxxabi.h to check for __cxa_eh_globals, __cxa_exception", but which appear to have been harmless as (a) the checked-for __cxxabiv1::__cxa_exceptions never existed in cxxabi.h, and (b) lack of __cxxabiv1::__cxa_exception in cxxabi.h happened to conincide with !HAVE_CXXABI_H_CXA_EH_GLOBALS Change-Id: I13f8a2b3cf0f03f2bc96cf053d2b571860055978 Reviewed-on: https://gerrit.libreoffice.org/85373 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ba5e87ea1641..ad246a64f37a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6312,14 +6312,14 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
- AC_MSG_CHECKING([whether $CXX_BASE defines __cxa_exceptions in cxxabi.h])
+ AC_MSG_CHECKING([whether $CXX_BASE defines __cxa_exception in cxxabi.h])
AC_LANG_PUSH([C++])
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <cstddef>
#include <cxxabi.h>
- std::size_t f() { return sizeof(__cxxabiv1::__cxa_exceptions); }
+ std::size_t f() { return sizeof(__cxxabiv1::__cxa_exception); }
])], [
- AC_DEFINE([HAVE_CXXABI_H_CXA_EXCEPTIONS],[1])
+ AC_DEFINE([HAVE_CXXABI_H_CXA_EXCEPTION],[1])
AC_MSG_RESULT([yes])
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])