summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-12-03 19:44:44 +0100
committerStephan Bergmann <sbergman@redhat.com>2020-12-03 20:45:52 +0100
commit91a360472f50cf58edeaf7a05a9a511dc9a5718b (patch)
treea0a2efe9e518593ec738a8f47cb5b36564737a4d /configure.ac
parent004ad8805429930ca6aa122b3c38c496ce849e61 (diff)
At least Clang 12 trunk understands -std=c++2b now
...since <https://github.com/llvm/llvm-project/commit/ 6627a3c2873fdf7ccba1a1573371079be48b36e8> "[c++2b] Add option -std=c++2b to enable support for potential C++2b features." Change-Id: I56b689c740c4269fa5ee29976ed8b0c17a04e6a1 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107175 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3f418e27bb10..bc71599f53c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7042,7 +7042,7 @@ if test "$COM" = MSC -a "$COM_IS_CLANG" != TRUE; then
elif test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
my_flags='-std=c++17 -std=c++1z'
if test "$with_latest_c__" = yes; then
- my_flags="-std=c++20 -std=c++2a $my_flags"
+ my_flags="-std=c++2b -std=c++20 -std=c++2a $my_flags"
fi
for flag in $my_flags; do
if test "$COM" = MSC; then