summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2019-11-19 18:08:07 +0100
committerLuboš Luňák <l.lunak@collabora.com>2019-11-27 09:55:18 +0100
commit7e5e3b8b0831d9f6aff7481d1163a366e76141d7 (patch)
treef0d6d73d61c96d69e99b851466817bcfdb3526eb /configure.ac
parentc2709d9fe2711a3729225ec9168f7acf5a7ba23c (diff)
build Skia only on selected platforms
Feel free to adjust your platform as necessary. Change-Id: I3003a643c39b6afeb3102f97280f20534b9c7f77
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 20cde192061e..04f8330a9ac8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -590,6 +590,7 @@ case "$host_os" in
solaris*)
build_gstreamer_1_0=yes
test_freetype=yes
+ build_skia=yes
_os=SunOS
dnl ===========================================================
@@ -616,6 +617,7 @@ linux-gnu*|k*bsd*-gnu*)
build_gstreamer_1_0=yes
test_kf5=yes
test_gtk3_kde5=yes
+ build_skia=yes
test_gdb_index=yes
test_split_debug=yes
if test "$enable_fuzzers" != yes; then
@@ -654,6 +656,7 @@ cygwin*|interix*)
test_xrender=no
test_freetype=no
test_fontconfig=no
+ build_skia=yes
_os=WINNT
DLLPOST=".dll"
@@ -708,6 +711,7 @@ freebsd*)
test_kf5=yes
test_gtk3_kde5=yes
test_freetype=yes
+ build_skia=yes
AC_MSG_CHECKING([the FreeBSD operating system release])
if test -n "$with_os_version"; then
OSVERSION="$with_os_version"
@@ -735,6 +739,7 @@ freebsd*)
test_kf5=yes
test_gtk3_kde5=yes
test_freetype=yes
+ build_skia=yes
PTHREAD_LIBS="-pthread -lpthread"
_os=NetBSD
;;
@@ -758,6 +763,7 @@ dragonfly*)
test_kf5=yes
test_gtk3_kde5=yes
test_freetype=yes
+ build_skia=yes
PTHREAD_LIBS="-pthread"
_os=DragonFly
;;
@@ -10882,7 +10888,7 @@ AC_SUBST(POPPLER_LIBS)
# Skia?
AC_MSG_CHECKING([whether to build Skia])
ENABLE_SKIA=
-if test "$enable_skia" != "no"; then
+if test "$enable_skia" != "no" -a "$build_skia" = "yes"; then
AC_MSG_RESULT([yes])
ENABLE_SKIA=TRUE
AC_DEFINE(HAVE_FEATURE_SKIA)