summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2019-09-05 16:43:14 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2019-09-23 12:57:08 +0200
commit6d09dcf0d8a8fd3b63ad583befaf2c47f85b16b7 (patch)
tree916a8b8851ff7a5dcd5df4e21801663c3a83fc47 /configure.ac
parent29ad26ace6cef4655c89902a7ec2c999cc4551e6 (diff)
android: add support for 64bit build
Change-Id: Id8aae84308f6128351ae2f93c8fbc8941a0c7fc6 Reviewed-on: https://gerrit.libreoffice.org/79085 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f27b041ee0c4..51767f9c537a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,6 +436,13 @@ if test -n "$with_android_ndk"; then
# minimum android version that supports aarch64
ANDROID_API_LEVEL=21
ANDROID_APP_ABI=arm64-v8a
+ elif test $host_cpu = x86_64; then
+ android_platform_prefix=x86_64-linux-android
+ android_gnu_prefix=$android_platform_prefix
+ LLVM_TRIPLE=$android_platform_prefix
+ # minimum android version that supports x86_64
+ ANDROID_API_LEVEL=21
+ ANDROID_APP_ABI=x86_64
else
# host_cpu is something like "i386" or "i686" I guess, NDK uses
# "x86" in some contexts
@@ -4472,6 +4479,11 @@ linux-android*)
RTL_ARCH=x86
PLATFORMID=android_x86
;;
+ x86_64)
+ CPUNAME=X86_64
+ RTL_ARCH=X86_64
+ PLATFORMID=android_x86_64
+ ;;
*)
AC_MSG_ERROR([Unsupported host_cpu $host_cpu for host_os $host_os])
;;