summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-03-09 11:25:29 +0100
committerStephan Bergmann <sbergman@redhat.com>2020-03-09 13:48:35 +0100
commit5ab0f79748cad1069cc0d0c9cd4b57ccb1e14408 (patch)
treea55ac52972424a190f0cbdf1504855a23ddca985 /configure.ac
parent633b2f4dffedaf4a162a5fa92eeaeb509efab173 (diff)
Add --disable-compiler-plugins-analyzer-pch for Jenkins/linux_clang_dbgutil_64
<https://ci.libreoffice.org/job/gerrit_linux_clang_dbgutil/54883/> had been a case I noticed of a "Gerrit Linux clang/dbgutil" build failing due to stale PCH information: [...] > [build GEN] compilerplugins/clang/sharedvisitor/makeshared.plugininfo > fatal error: file '/usr/include/asm-generic/errno.h' has been modified since the precompiled header '/home/tdf/lode/jenkins/workspace/lo_gerrit/Config/linux_clang_dbgutil_64/compilerplugins/clang/sharedvisitor/clang.pch' was built > note: please rebuild precompiled header '/home/tdf/lode/jenkins/workspace/lo_gerrit/Config/linux_clang_dbgutil_64/compilerplugins/clang/sharedvisitor/clang.pch' [...] and this issue had apparently caused all those Gerrit Jenkins builds to fail for at least a day. For unmaintained builds like those, I think it is better to have a more robust setup, where stale PCH information cannot break the build. Also, as those builds do not make compilerplugins.clean and rather share it across builds, there should not be much of a performance impact when disabling PCH in the analyzer. (It turns out that compilerplugins/clang/sharedvisitor/analyzer.cxx would always have enabled PCH, as compilerplugins/Makefile-clang.mk always passes in some definition of LO_CLANG_USE_ANALYZER_PCH. Fixed that now.) Change-Id: I7b8b24c1049c501634bd59c5fb482bec72427cf6 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/90211 Reviewed-by: Luboš Luňák <l.lunak@collabora.com> Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d17299ecd23f..e82bc1b5adf5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1223,6 +1223,11 @@ if test "$enable_compiler_plugins" = debug; then
COMPILER_PLUGINS_DEBUG=TRUE
fi
+libo_FUZZ_ARG_ENABLE(compiler-plugins-analyzer-pch,
+ AS_HELP_STRING([--disable-compiler-plugins-analyzer-pch],
+ [Disable use of precompiled headers when running the Clang compiler plugin analyzer. Not
+ relevant in the --disable-compiler-plugins case.]))
+
libo_FUZZ_ARG_ENABLE(ooenv,
AS_HELP_STRING([--disable-ooenv],
[Disable ooenv for the instdir installation.]))
@@ -7336,7 +7341,12 @@ else
AC_MSG_ERROR([Compiler plugins are currently supported only with the Clang compiler.])
fi
fi
+COMPILER_PLUGINS_ANALYZER_PCH=
+if test "$enable_compiler_plugins_analyzer_pch" != no; then
+ COMPILER_PLUGINS_ANALYZER_PCH=TRUE
+fi
AC_SUBST(COMPILER_PLUGINS)
+AC_SUBST(COMPILER_PLUGINS_ANALYZER_PCH)
AC_SUBST(COMPILER_PLUGINS_COM_IS_CLANG)
AC_SUBST(COMPILER_PLUGINS_CXX)
AC_SUBST(COMPILER_PLUGINS_CXXFLAGS)