summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2019-10-12 16:24:03 +0200
committerLuboš Luňák <l.lunak@collabora.com>2019-11-27 09:55:05 +0100
commit478f290e45c9cbf49576889088ea4dd71972d64b (patch)
treeded03f7b1915015956f85581da68d83d05de8520 /configure.ac
parent3a6f270edfffb97763927b2732feacedbdac1e80 (diff)
initial build of the Skia library
Not quite complete yet, missing e.g. Vulkan sources, and the setup is not completely correct either. Change-Id: I2283bf12f0d226ff8a34554deae5a7bd69045971
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08bdbc06c9ef..87f3d7d3dd38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1050,6 +1050,11 @@ libo_FUZZ_ARG_ENABLE(pdfium,
[Disable building PDFium.])
)
+libo_FUZZ_ARG_ENABLE(skia,
+ AS_HELP_STRING([--enable-skia],
+ [Enable building Skia.])
+)
+
###############################################################################
dnl ---------- *** ----------
@@ -10874,6 +10879,19 @@ AC_SUBST(SYSTEM_POPPLER)
AC_SUBST(POPPLER_CFLAGS)
AC_SUBST(POPPLER_LIBS)
+# Skia?
+AC_MSG_CHECKING([whether to build Skia])
+ENABLE_SKIA=
+if test "$enable_skia" = "yes"; then
+ AC_MSG_RESULT([yes])
+ ENABLE_SKIA=TRUE
+ AC_DEFINE(HAVE_FEATURE_SKIA)
+ BUILD_TYPE="$BUILD_TYPE SKIA"
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_SKIA)
+
SYSTEM_GPGMEPP=
if test "$build_for_ios" = "YES"; then