summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2015-05-12 12:10:16 +0200
committerDavid Tardon <dtardon@redhat.com>2015-05-12 12:14:54 +0200
commitd8eee8e4d1a303044bf34b28c2e95bd6da23fd79 (patch)
tree70d58a31a061a4f243a712745e8348ec612f1645 /configure.ac
parentd2ef03ce0b9295034f9078bc04acbf4cfc939ef6 (diff)
java dir for powepc64 and powepc64le can differ
E.g., RHEL >= 7.1 uses ppc64le for reasons listed in https://bugs.openjdk.java.net/browse/JDK-8073139 . This is a follow-up to commit 7a66dbe982623be620ad6ac426fe689a434e5f51. Change-Id: I685f76d51e9775788a7fb225c6a5e2309a45ceb7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 55157a9e1ae2..541475429da3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7002,6 +7002,7 @@ then
;;
powerpc64le)
AS_IF([test -d "$JAVA_HOME/jre/lib/ppc64le"], [my_java_arch=ppc64le], [my_java_arch=ppc64])
+ JAVA_ARCH=$my_java_arch
;;
x86_64)
my_java_arch=amd64
@@ -7011,6 +7012,7 @@ then
;;
esac
JAWTLIB="-L$JAVA_HOME/jre/lib/$my_java_arch -ljawt"
+ AS_IF([test "$JAVA_ARCH" != ""], [AC_DEFINE_UNQUOTED([JAVA_ARCH], ["$JAVA_ARCH"])])
fi
AC_MSG_RESULT([$JAWTLIB])
fi
@@ -12988,6 +12990,7 @@ AC_CONFIG_HEADERS([config_host/config_folders.h])
AC_CONFIG_HEADERS([config_host/config_gcc.h])
AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])
+AC_CONFIG_HEADERS([config_host/config_java.h])
AC_CONFIG_HEADERS([config_host/config_lgpl.h])
AC_CONFIG_HEADERS([config_host/config_liblangtag.h])
AC_CONFIG_HEADERS([config_host/config_locales.h])