summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2019-11-20 16:06:13 +0100
committerAndras Timar <andras.timar@collabora.com>2020-05-18 17:43:03 +0200
commite688b4259deacd8005d98f8497ea3101ffe4fd11 (patch)
tree9da19854a35fdc0901e4527f13ec0bf1a952b5bf /configure.ac
parent68fc9688f36f420e16f87de4da3b3ce75288b76c (diff)
android: Introduce --enable-android-lok configure switch to fix RGB vs. BGR.
This indicates that the build targets the Online-based Android app, for which we need to avoid various tweaks that are needed for the 'old' Android app present in the android/ subdir of core.git. In particular, the switch used in this patch fixes a RGBA vs. BGRA confusion that caused yellow <-> cyan switch in the Online-based Android app. Change-Id: I5f394868f51ce87013677834cfafb967b9bb333e Reviewed-on: https://gerrit.libreoffice.org/83342 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Jan Holesovsky <kendy@collabora.com> (cherry picked from commit 49002a143a4534df5f6139e07fefd06174621c59) Reviewed-on: https://gerrit.libreoffice.org/83718 Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 29e7a815dd25..47714298a438 100644
--- a/configure.ac
+++ b/configure.ac
@@ -545,6 +545,25 @@ if test -n "$with_android_sdk"; then
fi
AC_SUBST(ANDROID_SDK_HOME)
+AC_ARG_ENABLE([android-lok],
+ AS_HELP_STRING([--enable-android-lok],
+ [The Android app from the android/ subdir needs several tweaks all
+ over the place that break the LOK when used in the Online-based
+ Android app. This switch indicates that the intent of this build is
+ actually the Online-based, non-modified LOK.])
+)
+ENABLE_ANDROID_LOK=
+if test -n "$ANDROID_NDK_HOME" ; then
+ if test "$enable_android_lok" = yes; then
+ ENABLE_ANDROID_LOK=TRUE
+ AC_DEFINE(HAVE_FEATURE_ANDROID_LOK)
+ AC_MSG_NOTICE([building the Android version... for the Online-based Android app])
+ else
+ AC_MSG_NOTICE([building the Android version... for the app from the android/ subdir])
+ fi
+fi
+AC_SUBST([ENABLE_ANDROID_LOK])
+
libo_FUZZ_ARG_ENABLE([android-editing],
AS_HELP_STRING([--enable-android-editing],
[Enable the experimental editing feature on Android.])